summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-07-12 22:37:05 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-07-12 22:37:40 +0100
commit4496cbadab513d1fad737d48637a5a731b37b537 (patch)
tree3774832e85a57caf254f99c39e19734657791214 /sys-devel/sparse
parentgnome-extra/gnome-shell-extensions: bump to 3.36.2 (diff)
downloadgentoo-4496cbadab513d1fad737d48637a5a731b37b537.tar.gz
gentoo-4496cbadab513d1fad737d48637a5a731b37b537.tar.bz2
gentoo-4496cbadab513d1fad737d48637a5a731b37b537.zip
sys-devel/sparse: bump up to 0.6.2
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/sparse')
-rw-r--r--sys-devel/sparse/Manifest1
-rw-r--r--sys-devel/sparse/sparse-0.6.2.ebuild72
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild6
3 files changed, 77 insertions, 2 deletions
diff --git a/sys-devel/sparse/Manifest b/sys-devel/sparse/Manifest
index 69ecd80dccb2..088da04a4f88 100644
--- a/sys-devel/sparse/Manifest
+++ b/sys-devel/sparse/Manifest
@@ -1 +1,2 @@
DIST sparse-0.6.1.tar.xz 287880 BLAKE2B 026e7770460ab576b91e8c401c642e95269ddd7c90c0f855b0246448ca653b95a899b4bf647134c090c06c802757b6415dcc89bc214fb7ff124c2ce3888fccb0 SHA512 2faad9b3263f19f941cd6a5891960d2c7d1066c664d3ef68e722d461785aeed2d4a9539df3556bbd98c022e7ee965b8030c49272ab6003113ba3b36f73c00187
+DIST sparse-0.6.2.tar.xz 340100 BLAKE2B 72463fe93753f2cdced3411d1ccb18cc30dce82c4f6ae6289cf4297c66cee9f52ba96f96cceac1f134b017a7d6691b019c2f22cc801522e7a0fe0c5e0b4c8da4 SHA512 43c16b5cb4141077dd51f93e877e28e1a00e69ced58a9c8f643635b6f87a8044cddfe29a734b4a43282748e12f287b19b4fb3ce8c5e0b13931a3355974dff982
diff --git a/sys-devel/sparse/sparse-0.6.2.ebuild b/sys-devel/sparse/sparse-0.6.2.ebuild
new file mode 100644
index 000000000000..8860a29313e7
--- /dev/null
+++ b/sys-devel/sparse/sparse-0.6.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils llvm multilib toolchain-funcs
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="https://sparse.wiki.kernel.org/index.php/Main_Page"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/devel/${PN}/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://www.kernel.org/pub/software/devel/${PN}/dist/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gtk llvm sqlite test xml"
+RESTRICT="!test? ( test )"
+
+LLVM_MAX_SLOT=10
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ llvm? ( sys-devel/llvm:${LLVM_MAX_SLOT}= )
+ sqlite? ( dev-db/sqlite:= )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )
+ xml? ( virtual/pkgconfig )"
+
+pkg_setup() {
+ use llvm && llvm_pkg_setup
+}
+
+_emake() {
+ # Makefile does not allow for an easy override of flags.
+ # Collect them here and override default phases.
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ CFLAGS="${CFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ \
+ HAVE_GTK=$(usex gtk) \
+ HAVE_LLVM=$(usex llvm) \
+ HAVE_SQLITE=$(usex sqlite) \
+ HAVE_LIBXML=$(usex xml) \
+ \
+ V=1 \
+ PREFIX="${EPREFIX}/usr" \
+ \
+ "$@"
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ _emake DESTDIR="${D}" install
+
+ dodoc FAQ README
+}
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index d058d2c9ea40..8860a29313e7 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -19,13 +19,14 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="gtk llvm test xml"
+IUSE="gtk llvm sqlite test xml"
RESTRICT="!test? ( test )"
-LLVM_MAX_SLOT=9
+LLVM_MAX_SLOT=10
RDEPEND="gtk? ( x11-libs/gtk+:2 )
llvm? ( sys-devel/llvm:${LLVM_MAX_SLOT}= )
+ sqlite? ( dev-db/sqlite:= )
xml? ( dev-libs/libxml2 )"
DEPEND="${RDEPEND}
gtk? ( virtual/pkgconfig )
@@ -47,6 +48,7 @@ _emake() {
\
HAVE_GTK=$(usex gtk) \
HAVE_LLVM=$(usex llvm) \
+ HAVE_SQLITE=$(usex sqlite) \
HAVE_LIBXML=$(usex xml) \
\
V=1 \