summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-28 05:27:14 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-28 05:28:35 +0100
commit1bb2c9f6643f2d7938630d59825842eef7cc65da (patch)
tree97ae01b98275538e3001e3817f0ed87bf4eaf25a /sys-devel
parentdev-lang/rust-bin: add openssl{,-compat} dep (diff)
downloadgentoo-1bb2c9f6643f2d7938630d59825842eef7cc65da.tar.gz
gentoo-1bb2c9f6643f2d7938630d59825842eef7cc65da.tar.bz2
gentoo-1bb2c9f6643f2d7938630d59825842eef7cc65da.zip
sys-devel/llvm: Reenable EH/RTTI in *.9999
This will also be the part of the next 16.x RC and 17.x snapshot. Bug: https://bugs.gentoo.org/884193 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-16.0.0.9999.ebuild2
-rw-r--r--sys-devel/llvm/llvm-17.0.0.9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-16.0.0.9999.ebuild b/sys-devel/llvm/llvm-16.0.0.9999.ebuild
index fcb512276fe7..d05904f7192f 100644
--- a/sys-devel/llvm/llvm-16.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-16.0.0.9999.ebuild
@@ -360,6 +360,8 @@ multilib_src_configure() {
-DLLVM_ENABLE_LIBXML2=$(usex xml)
-DLLVM_ENABLE_ASSERTIONS=$(usex debug)
-DLLVM_ENABLE_LIBPFM=$(usex exegesis)
+ -DLLVM_ENABLE_EH=ON
+ -DLLVM_ENABLE_RTTI=ON
-DLLVM_ENABLE_Z3_SOLVER=$(usex z3)
-DLLVM_ENABLE_ZSTD=$(usex zstd)
diff --git a/sys-devel/llvm/llvm-17.0.0.9999.ebuild b/sys-devel/llvm/llvm-17.0.0.9999.ebuild
index fcb512276fe7..d05904f7192f 100644
--- a/sys-devel/llvm/llvm-17.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-17.0.0.9999.ebuild
@@ -360,6 +360,8 @@ multilib_src_configure() {
-DLLVM_ENABLE_LIBXML2=$(usex xml)
-DLLVM_ENABLE_ASSERTIONS=$(usex debug)
-DLLVM_ENABLE_LIBPFM=$(usex exegesis)
+ -DLLVM_ENABLE_EH=ON
+ -DLLVM_ENABLE_RTTI=ON
-DLLVM_ENABLE_Z3_SOLVER=$(usex z3)
-DLLVM_ENABLE_ZSTD=$(usex zstd)