summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2019-04-13 12:33:27 +0200
committerTiziano Müller <dev-zero@gentoo.org>2019-04-13 12:36:34 +0200
commit1f0a334057d92489c4f2749085194910767653da (patch)
treecbc2b7d8ae9e64082f3148700981ad1bdf6d9505 /sys-devel
parentnet-vpn/tor: version bump to 0.4.0.4_rc (diff)
downloadgentoo-1f0a334057d92489c4f2749085194910767653da.tar.gz
gentoo-1f0a334057d92489c4f2749085194910767653da.tar.bz2
gentoo-1f0a334057d92489c4f2749085194910767653da.zip
sys-devel/dwz: fix calling cc directly
Closes: https://bugs.gentoo.org/683024 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Tiziano Müller <dev-zero@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/dwz/dwz-0.12-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-devel/dwz/dwz-0.12-r1.ebuild b/sys-devel/dwz/dwz-0.12-r1.ebuild
new file mode 100644
index 000000000000..9926eba6d80b
--- /dev/null
+++ b/sys-devel/dwz/dwz-0.12-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+FPKG_HASH="1624afa75b94633e03c6e1bb952fb348"
+
+DESCRIPTION="DWARF optimization and duplicate removal tool"
+HOMEPAGE="https://sourceware.org/git/?p=dwz.git;a=summary"
+SRC_URI="https://src.fedoraproject.org/repo/pkgs/dwz/${P}.tar.bz2/${FPKG_HASH}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-libs/elfutils"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^CFLAGS/d' \
+ Makefile || die "sed failed"
+ tc-export CC
+}