summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-18 00:25:42 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-28 10:14:16 +0100
commit35913dc12dfc8f34db766d410e9ee60866c223b2 (patch)
tree3ee2016141192293f8bf38a4647090e8e55c09c2 /sys-devel
parentgit-r3.eclass: Support checking out specific subdirectories (diff)
downloadgentoo-35913dc12dfc8f34db766d410e9ee60866c223b2.tar.gz
gentoo-35913dc12dfc8f34db766d410e9ee60866c223b2.tar.bz2
gentoo-35913dc12dfc8f34db766d410e9ee60866c223b2.zip
sys-devel/llvm-common: Utilize partial git checkouts
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm-common/llvm-common-5.0.9999.ebuild5
-rw-r--r--sys-devel/llvm-common/llvm-common-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-5.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-5.0.9999.ebuild
index 239d0e083cd5..cc7ed2a71228 100644
--- a/sys-devel/llvm-common/llvm-common-5.0.9999.ebuild
+++ b/sys-devel/llvm-common/llvm-common-5.0.9999.ebuild
@@ -19,6 +19,11 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/vim
+}
+
src_configure() { :; }
src_compile() { :; }
src_test() { :; }
diff --git a/sys-devel/llvm-common/llvm-common-9999.ebuild b/sys-devel/llvm-common/llvm-common-9999.ebuild
index 64d8f5e7daf3..d0f42029fa97 100644
--- a/sys-devel/llvm-common/llvm-common-9999.ebuild
+++ b/sys-devel/llvm-common/llvm-common-9999.ebuild
@@ -18,6 +18,11 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/vim
+}
+
src_configure() { :; }
src_compile() { :; }
src_test() { :; }