summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-07 20:55:27 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-07 20:55:27 +0200
commit4a58589864d4a047375fff2c9f62c3006ff65f8d (patch)
tree45597bf8e31310f8e0f4e96a61d05cf9ff64914c /sys-devel
parentdev-python/pyramid: Bump to 1.5.8 (to fix tests) (diff)
downloadgentoo-4a58589864d4a047375fff2c9f62c3006ff65f8d.tar.gz
gentoo-4a58589864d4a047375fff2c9f62c3006ff65f8d.tar.bz2
gentoo-4a58589864d4a047375fff2c9f62c3006ff65f8d.zip
sys-devel/flex: Bump to version 2.6.4
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/flex/Manifest1
-rw-r--r--sys-devel/flex/flex-2.6.4.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/sys-devel/flex/Manifest b/sys-devel/flex/Manifest
index 7e63a4ea6ff8..db996620924b 100644
--- a/sys-devel/flex/Manifest
+++ b/sys-devel/flex/Manifest
@@ -1,2 +1,3 @@
DIST flex-2.6.1.tar.xz 835048 SHA256 2c7a412c1640e094cb058d9b2fe39d450186e09574bebb7aa28f783e3799103f SHA512 1e35d0447f59139b98ede085d1a603d4f61cf8bc11cf2e291a3f492a05c60ee61535481b878585cd6843cd9b3c7952c834adfa78a6a71c64802e7b3069dec9d1 WHIRLPOOL d671017fd516f5d6457a896f1d50d4a4d310d32476a6db8f1ed99305a96955eec7586d8ef2aff1e03795be3f7417e0f1d8925b073788a14abcdd38868822eb67
DIST flex-2.6.3.tar.gz 1405560 SHA256 68b2742233e747c462f781462a2a1e299dc6207401dac8f0bbb316f48565c2aa SHA512 f14b1af7ddd148660737991787fcf13d86cc0bef3859ed6c2135963373e76524d70382795c845cb6491b0435f8c40ba81e17f15267592b8d1656cfd4c3430b00 WHIRLPOOL 266266c4c15135fe52ec3b5226645b89c7053ec4dac257c9349d760601eaf50f7ec504d3c4b74951fd415d17299c2ca2e483e8c8c7f8ee936b4822d92603a4e2
+DIST flex-2.6.4.tar.gz 1419096 SHA256 e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995 SHA512 e9785f3d620a204b7d20222888917dc065c2036cae28667065bf7862dfa1b25235095a12fd04efdbd09bfd17d3452e6b9ef953a8c1137862ff671c97132a082e WHIRLPOOL b19880ae3d760e04138ca93c848da07baa004bd193616855f1e650a170648288727d6a2bb5e657f05b204505d4b5b70e76a795037c81c6a19e1767cebadf8204
diff --git a/sys-devel/flex/flex-2.6.4.ebuild b/sys-devel/flex/flex-2.6.4.ebuild
new file mode 100644
index 000000000000..6ab22250d5fc
--- /dev/null
+++ b/sys-devel/flex/flex-2.6.4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils flag-o-matic libtool multilib-minimal
+
+DESCRIPTION="The Fast Lexical Analyzer"
+HOMEPAGE="https://flex.sourceforge.net/ https://github.com/westes/flex"
+SRC_URI="https://github.com/westes/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="FLEX"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static test"
+
+# We want bison explicitly and not yacc in general #381273
+RDEPEND="sys-devel/m4"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )
+ test? ( sys-devel/bison )"
+
+src_prepare() {
+ #epatch "${PATCHES[@]}"
+
+ # Disable running in the tests/ subdir as it has a bunch of built sources
+ # that cannot be made conditional (automake limitation). #568842
+ if ! use test ; then
+ sed -i \
+ -e '/^SUBDIRS =/,/^$/{/tests/d}' \
+ Makefile.in || die
+ fi
+ elibtoolize # Prefix always needs this
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ # Do not install shared libs #503522
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-shared \
+ $(use_enable nls) \
+ --docdir='$(datarootdir)/doc/'${PF}
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ default
+ else
+ cd src || die
+ emake -f Makefile -f - lib <<< 'lib: $(lib_LTLIBRARIES)'
+ fi
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && emake check
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ default
+ else
+ cd src || die
+ emake DESTDIR="${D}" install-libLTLIBRARIES install-includeHEADERS
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dodoc ONEWS
+ prune_libtool_files --all
+ rm "${ED}"/usr/share/doc/${PF}/COPYING || die
+ dosym flex /usr/bin/lex
+}