summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 09:34:44 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-01 14:15:48 +0100
commit57175b7d339c719de9a65a60f849f62d230ac3ea (patch)
tree6501cd67a04bc4994054ada4955e70d3aa956cef /sys-devel
parentsys-devel/clang: Switch live to monorepo (diff)
downloadgentoo-57175b7d339c719de9a65a60f849f62d230ac3ea.tar.gz
gentoo-57175b7d339c719de9a65a60f849f62d230ac3ea.tar.bz2
gentoo-57175b7d339c719de9a65a60f849f62d230ac3ea.zip
sys-devel/lld: Switch live to monorepo
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/lld/lld-10.0.0.9999.ebuild20
-rw-r--r--sys-devel/lld/lld-9.0.1.9999.ebuild22
2 files changed, 13 insertions, 29 deletions
diff --git a/sys-devel/lld/lld-10.0.0.9999.ebuild b/sys-devel/lld/lld-10.0.0.9999.ebuild
index 9d1c88d828d3..c0a2e884c80d 100644
--- a/sys-devel/lld/lld-10.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-10.0.0.9999.ebuild
@@ -13,8 +13,8 @@ inherit cmake-utils git-r3 llvm multiprocessing python-any-r1
DESCRIPTION="The LLVM linker (link editor)"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/lld.git
- https://github.com/llvm-mirror/lld.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/lld
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -39,18 +39,10 @@ pkg_setup() {
}
src_unpack() {
- if use test; then
- # needed for patched gtest
- git-r3_fetch "https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
- fi
+ local dirs=( lld )
+ use test && dirs+=( llvm/utils/{lit,unittest} )
git-r3_fetch
-
- if use test; then
- git-r3_checkout https://llvm.org/git/llvm.git \
- "${WORKDIR}"/llvm '' utils/{lit,unittest}
- fi
- git-r3_checkout
+ git-r3_checkout '' '' '' "${dirs[@]}"
}
src_configure() {
@@ -61,7 +53,7 @@ src_configure() {
)
use test && mycmakeargs+=(
-DLLVM_BUILD_TESTS=ON
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DLLVM_MAIN_SRC_DIR="${WORKDIR}/${P}/llvm"
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)
diff --git a/sys-devel/lld/lld-9.0.1.9999.ebuild b/sys-devel/lld/lld-9.0.1.9999.ebuild
index 6935200f15c6..07ffc6f41c97 100644
--- a/sys-devel/lld/lld-9.0.1.9999.ebuild
+++ b/sys-devel/lld/lld-9.0.1.9999.ebuild
@@ -13,9 +13,9 @@ inherit cmake-utils git-r3 llvm multiprocessing python-any-r1
DESCRIPTION="The LLVM linker (link editor)"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/lld.git
- https://github.com/llvm-mirror/lld.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/lld
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -40,18 +40,10 @@ pkg_setup() {
}
src_unpack() {
- if use test; then
- # needed for patched gtest
- git-r3_fetch "https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
- fi
+ local dirs=( lld )
+ use test && dirs+=( llvm/utils/{lit,unittest} )
git-r3_fetch
-
- if use test; then
- git-r3_checkout https://llvm.org/git/llvm.git \
- "${WORKDIR}"/llvm '' utils/{lit,unittest}
- fi
- git-r3_checkout
+ git-r3_checkout '' '' '' "${dirs[@]}"
}
src_configure() {
@@ -62,7 +54,7 @@ src_configure() {
)
use test && mycmakeargs+=(
-DLLVM_BUILD_TESTS=ON
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DLLVM_MAIN_SRC_DIR="${WORKDIR}/${P}/llvm"
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)