summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-01-27 12:25:52 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-01-27 12:47:21 +0100
commit724b7e19983a45eb3fadce702610536f218f25b7 (patch)
tree1aa198b683d6532dd53822ea2e5e6be9acde63be /sys-devel
parentapp-editors/wily: Drop USE dependency for dev-libs/9libs[X] (diff)
downloadgentoo-724b7e19983a45eb3fadce702610536f218f25b7.tar.gz
gentoo-724b7e19983a45eb3fadce702610536f218f25b7.tar.bz2
gentoo-724b7e19983a45eb3fadce702610536f218f25b7.zip
sys-devel/bison: Bump to version 3.3
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/Manifest2
-rw-r--r--sys-devel/bison/bison-3.3.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index 0fea59ccd9bf..cf7067336daf 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -3,3 +3,5 @@ DIST bison-3.1.tar.xz 1990536 BLAKE2B 6223642f2934927ca118410e2655f7c677bb1d3d98
DIST bison-3.2.3-patches-01.tar.xz 9460 BLAKE2B 3e9f3e636d774d005c861c4f5fe121a862cbfc38f5efd5bb7ac7d2944f71e80eabd6621f3f5507d9f78727f22b574581c9b694457c63b5181a8cc1a0ac69d294 SHA512 6c599583b67f8999c8e2c8492a19ad0b43bbadef1d9c062c752e7c1cc3d178c2106262c70c998a0588bc6255ec27b2623a90267e0858e2d776ac2f4cf6cb688f
DIST bison-3.2.3.tar.xz 2092048 BLAKE2B b5f98850e1b69fcc0f5e559c12708cde59f00f2e633b7a2a0c9ddc849f548265bb30873e4e64e1b2a72e51cb5f1caef7ec0ab09aa2c8d7dae04ae71854da7096 SHA512 6f86ebc0d66e8dcd3709b25938b2bf43b94e7f4a0a20e586ba42c55c8747543fb48ca47cc2116e4bad8d2152de58c8c75b284a9b254ab8c8ecef292967657494
DIST bison-3.2.4.tar.xz 2094568 BLAKE2B 9b7617b25f1b151c3b86a5f57e733543160fb40f992ff968eaadfc91d8f1a67f56d0afeafbed5003ea1a5e0c861b12ef4cc27065d1b6cbc1d0845710164d84e2 SHA512 652b54fdee969bbc17eeb04d05d65f143e8e0e1b46ac2574e3a76687b9bd916c9a0c97658b4f8357958d64e87fe2a6a2a98a6c312970f0e74fb4445962e9daae
+DIST bison-3.3-patches-01.tar.xz 10768 BLAKE2B 6b4df80d0cf6ff3445019bbc66063b794731d2c9869b20b0ace3ed9500e7ea4a30685a4084717871a68838b31392a90d2e1b52ef01eb2f62ea420e513268652c SHA512 32accc5a9e7b18b8dd98c73e5da50018be68effed9b69ed4d30604c7e7ba4495eef54b7882c3fe32bdeffb9278165ac2b5f3164b7c122e2001e4dd60ac2f4d1a
+DIST bison-3.3.tar.xz 2104368 BLAKE2B ca7cf55296d9df9f157e98152536732a64e2bf54850e7641ef67d441abc823f4ab08f7b0fd74358d33cd7933f48a160e870b918f2673cd5080207e4789c20419 SHA512 6b67c50c7e51b7a56aaf12f4e4895207ac54ae43fb27e93fc984b250802a66cf7edb227c4b643832b3327b30bafc7636af1ee306c0ead5d4762764311767bea1
diff --git a/sys-devel/bison/bison-3.3.ebuild b/sys-devel/bison/bison-3.3.ebuild
new file mode 100644
index 000000000000..ca879edb2437
--- /dev/null
+++ b/sys-devel/bison/bison-3.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic
+
+PATCHES="${PN}-3.3-patches-01.tar.xz"
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="https://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ https://dev.gentoo.org/~whissi/dist/bison/${PATCHES}
+ https://dev.gentoo.org/~polynomial-c/dist/bison/${PATCHES}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples nls static test"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ examples? ( dev-lang/perl )
+ nls? ( sys-devel/gettext )
+ test? ( dev-lang/perl )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO ) # ChangeLog-2012 ChangeLog-1998 PACKAGING README-alpha README-release
+
+PATCHES=(
+ "${WORKDIR}"/patches/${PN}-3.1-optional-perl.patch #538300
+ "${WORKDIR}"/patches/${PN}-3.3-avoid_autoreconf.patch
+)
+
+src_prepare() {
+ # Record date to avoid 'config.status --recheck' & regen of 'tests/package.m4'
+ touch -r configure.ac old.configure.ac || die
+ touch -r configure old.configure || die
+
+ default
+
+ # Restore date after patching
+ touch -r old.configure.ac configure.ac || die
+ touch -r old.configure configure || die
+
+ # The makefiles make the man page depend on the configure script
+ # which we patched above. Touch it to prevent regeneration.
+ touch doc/bison.1 || die #548778 #538300#9
+
+ # Avoid regenerating the info page when the timezone is diff. #574492
+ sed -i '2iexport TZ=UTC' build-aux/mdate-sh || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ --docdir='$(datarootdir)'/doc/${PF}
+ $(use_enable examples)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED%/}"/usr/bin/yacc{,.bison} || die
+ mv "${ED%/}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED%/}"/usr/lib* || die
+
+ # Move to documentation directory and leave compressing for EAPI>=4
+ mv "${ED%/}"/usr/share/${PN}/README "${ED%/}"/usr/share/doc/${PF}/README.data
+}
+
+pkg_postinst() {
+ local f="${EROOT%/}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT%/}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}