summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulius Putra Tanu Setiaji <indocomsoft@gmail.com>2019-12-18 21:59:05 +0800
committerMichał Górny <mgorny@gentoo.org>2019-12-22 09:16:27 +0100
commit74becb19ba7f7c46ae22e8a1ec6270e2caeaa725 (patch)
tree2ab885cab1f8a09e96379eb0ea3c188bb0abb722 /sys-devel
parentsys-kernel/vanilla-kernel: Bump to 5.4.6 (diff)
downloadgentoo-74becb19ba7f7c46ae22e8a1ec6270e2caeaa725.tar.gz
gentoo-74becb19ba7f7c46ae22e8a1ec6270e2caeaa725.tar.bz2
gentoo-74becb19ba7f7c46ae22e8a1ec6270e2caeaa725.zip
sys-devel/clang: Set the correct LLVM_CMAKE_PATH on Gentoo Prefix
Signed-off-by: Julius Putra Tanu Setiaji <indocomsoft@gmail.com> Closes: https://bugs.gentoo.org/696844 Package-Manager: Portage-2.3.82, Repoman-2.3.20 Closes: https://github.com/gentoo/gentoo/pull/14036 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/clang-10.0.0.9999.ebuild1
-rw-r--r--sys-devel/clang/clang-9.0.1.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-10.0.0.9999.ebuild b/sys-devel/clang/clang-10.0.0.9999.ebuild
index cdd1274c4236..8201088ceb49 100644
--- a/sys-devel/clang/clang-10.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-10.0.0.9999.ebuild
@@ -209,6 +209,7 @@ multilib_src_configure() {
local clang_version=$(ver_cut 1-3 "${llvm_version}")
local mycmakeargs=(
+ -DLLVM_CMAKE_PATH="${EPREFIX}/usr/lib/llvm/${SLOT}/$(get_libdir)/cmake/llvm"
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${SLOT}"
-DCMAKE_INSTALL_MANDIR="${EPREFIX}/usr/lib/llvm/${SLOT}/share/man"
# relative to bindir
diff --git a/sys-devel/clang/clang-9.0.1.ebuild b/sys-devel/clang/clang-9.0.1.ebuild
index 926c06a7ee9c..6d46d2519883 100644
--- a/sys-devel/clang/clang-9.0.1.ebuild
+++ b/sys-devel/clang/clang-9.0.1.ebuild
@@ -96,6 +96,7 @@ multilib_src_configure() {
local clang_version=$(ver_cut 1-3 "${llvm_version}")
local mycmakeargs=(
+ -DLLVM_CMAKE_PATH="${EPREFIX}/usr/lib/llvm/${SLOT}/$(get_libdir)/cmake/llvm"
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${SLOT}"
-DCMAKE_INSTALL_MANDIR="${EPREFIX}/usr/lib/llvm/${SLOT}/share/man"
# relative to bindir