summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-08-06 09:54:00 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-08-06 09:57:54 -0500
commitb877bfb4aaca027ba7e1da6945da5b4bf87cb063 (patch)
treeb7ceaa0d7e0998a2c711969f8e1eea00ca3b1d6e /sys-devel
parentnet-analyzer/nagios-check_rbl: disable the unintentional test suite. (diff)
downloadgentoo-b877bfb4aaca027ba7e1da6945da5b4bf87cb063.tar.gz
gentoo-b877bfb4aaca027ba7e1da6945da5b4bf87cb063.tar.bz2
gentoo-b877bfb4aaca027ba7e1da6945da5b4bf87cb063.zip
sys-devel/gcc: 4.9.4, bump patchset to 1.1, fix for bug #620164
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-4.9.4-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.9.4-r1.ebuild b/sys-devel/gcc/gcc-4.9.4-r1.ebuild
new file mode 100644
index 000000000000..cb7809f3fdd4
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.9.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.6.4"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 mips ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 mips ppc ppc64"
+SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 mips ppc ppc64 arm"
+#end Hardened stuff
+
+inherit eutils toolchain
+
+# KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_prepare() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ toolchain_src_prepare
+
+ use vanilla && return 0
+ #Use -r1 for newer piepatchet that use DRIVER_SELF_SPECS for the hardened specs.
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env-r1.patch
+}