summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2018-09-17 23:40:54 -0400
committerMike Frysinger <vapier@gentoo.org>2018-09-17 23:48:36 -0400
commitc467a8a6e70b793221cd1f6a6658894c2e4a190e (patch)
tree210d922f3f92649c4f0209397c3e786dbbcab364 /sys-devel
parentmail-filter/spamassassin: new version 3.4.2. (diff)
downloadgentoo-c467a8a6e70b793221cd1f6a6658894c2e4a190e.tar.gz
gentoo-c467a8a6e70b793221cd1f6a6658894c2e4a190e.tar.bz2
gentoo-c467a8a6e70b793221cd1f6a6658894c2e4a190e.zip
sys-devel/bc: replace ed usage with sed
The ed usage here is minor and easy enough to convert to sed. This avoids a depend that no one else generally has.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bc/bc-1.07.1-r2.ebuild2
-rw-r--r--sys-devel/bc/files/bc-1.07.1-no-ed-its-sed.patch23
2 files changed, 24 insertions, 1 deletions
diff --git a/sys-devel/bc/bc-1.07.1-r2.ebuild b/sys-devel/bc/bc-1.07.1-r2.ebuild
index 78cc0f0805f4..5a7d1afa3a78 100644
--- a/sys-devel/bc/bc-1.07.1-r2.ebuild
+++ b/sys-devel/bc/bc-1.07.1-r2.ebuild
@@ -23,13 +23,13 @@ RDEPEND="
"
DEPEND="
${RDEPEND}
- sys-apps/ed
sys-devel/flex
virtual/yacc
"
PATCHES=(
"${FILESDIR}/${PN}-1.07.1-sandbox.patch"
+ "${FILESDIR}/${PN}-1.07.1-no-ed-its-sed.patch"
)
src_prepare() {
diff --git a/sys-devel/bc/files/bc-1.07.1-no-ed-its-sed.patch b/sys-devel/bc/files/bc-1.07.1-no-ed-its-sed.patch
new file mode 100644
index 000000000000..ce8e456186b7
--- /dev/null
+++ b/sys-devel/bc/files/bc-1.07.1-no-ed-its-sed.patch
@@ -0,0 +1,23 @@
+in Gentoo, everyone has sed. no one really has ed. tweak this minor script
+to use sed instead of ed. the changes are straight forward:
+* change \$ to $
+* merge last two $,$ commands into one
+* delete w/q commands
+
+--- a/bc/fix-libmath_h
++++ b/bc/fix-libmath_h
+@@ -1,9 +1,6 @@
+-ed libmath.h <<EOS-EOS
++sed -i libmath.h -e '
+ 1,1s/^/{"/
+-1,\$s/\$/",/
+-2,\$s/^/"/
+-\$,\$d
+-\$,\$s/,\$/,0}/
+-w
+-q
+-EOS-EOS
++1,$s/$/",/
++2,$s/^/"/
++$s/.*/0}/
++'