summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 18:37:46 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-03 12:46:08 +0100
commitc6862fa57e51d8bd3d68d1a70dd12012b252dd50 (patch)
tree25ed966d14aa32ae00ee40d7489f8241312cda5f /sys-devel
parentllvm.org.eclass: New eclass to help maintaining LLVM (diff)
downloadgentoo-c6862fa57e51d8bd3d68d1a70dd12012b252dd50.tar.gz
gentoo-c6862fa57e51d8bd3d68d1a70dd12012b252dd50.tar.bz2
gentoo-c6862fa57e51d8bd3d68d1a70dd12012b252dd50.zip
sys-devel/llvm-common: Port 9+ to llvm.org.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm-common/llvm-common-10.0.0.9999.ebuild22
-rw-r--r--sys-devel/llvm-common/llvm-common-9.0.0.ebuild22
-rw-r--r--sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild23
3 files changed, 19 insertions, 48 deletions
diff --git a/sys-devel/llvm-common/llvm-common-10.0.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-10.0.0.9999.ebuild
index 7edf27153de4..ba2ffc76a706 100644
--- a/sys-devel/llvm-common/llvm-common-10.0.0.9999.ebuild
+++ b/sys-devel/llvm-common/llvm-common-10.0.0.9999.ebuild
@@ -3,13 +3,12 @@
EAPI=7
-inherit git-r3
+inherit llvm.org
DESCRIPTION="Common files shared between multiple slots of LLVM"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-S=${WORKDIR}/${P}/llvm
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -18,19 +17,10 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' llvm/utils/vim
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
src_install() {
insinto /usr/share/vim/vimfiles
- doins -r utils/vim/*/
+ doins -r */
# some users may find it useful
- newdoc utils/vim/README README.vim
- dodoc utils/vim/vimrc
+ newdoc README README.vim
+ dodoc vimrc
}
diff --git a/sys-devel/llvm-common/llvm-common-9.0.0.ebuild b/sys-devel/llvm-common/llvm-common-9.0.0.ebuild
index 65eb4d232e33..a81f8f505994 100644
--- a/sys-devel/llvm-common/llvm-common-9.0.0.ebuild
+++ b/sys-devel/llvm-common/llvm-common-9.0.0.ebuild
@@ -3,11 +3,12 @@
EAPI=7
-MY_P=llvm-${PV/_/}.src
+inherit llvm.org
+
DESCRIPTION="Common files shared between multiple slots of LLVM"
HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
-S=${WORKDIR}/${MY_P}
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -16,19 +17,10 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
-src_unpack() {
- einfo "Unpacking parts of ${MY_P}.tar.xz ..."
- tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/vim" || die
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
src_install() {
insinto /usr/share/vim/vimfiles
- doins -r utils/vim/*/
+ doins -r */
# some users may find it useful
- newdoc utils/vim/README README.vim
- dodoc utils/vim/vimrc
+ newdoc README README.vim
+ dodoc vimrc
}
diff --git a/sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild b/sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild
index b3b79ac4e6c6..ba2ffc76a706 100644
--- a/sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild
+++ b/sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild
@@ -3,14 +3,12 @@
EAPI=7
-inherit git-r3
+inherit llvm.org
DESCRIPTION="Common files shared between multiple slots of LLVM"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-EGIT_BRANCH="release/9.x"
-S=${WORKDIR}/${P}/llvm
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -19,19 +17,10 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' llvm/utils/vim
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
src_install() {
insinto /usr/share/vim/vimfiles
- doins -r utils/vim/*/
+ doins -r */
# some users may find it useful
- newdoc utils/vim/README README.vim
- dodoc utils/vim/vimrc
+ newdoc README README.vim
+ dodoc vimrc
}