summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-29 07:58:07 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-29 08:06:24 +0200
commitf091b5dce7c300551e1e7909a367a388f3df665d (patch)
tree05ffa67c27951eb2a6ff9a115c092ad85e8ca185 /sys-devel
parentdev-ruby/network_interface: add 0.0.2 (diff)
downloadgentoo-f091b5dce7c300551e1e7909a367a388f3df665d.tar.gz
gentoo-f091b5dce7c300551e1e7909a367a388f3df665d.tar.bz2
gentoo-f091b5dce7c300551e1e7909a367a388f3df665d.zip
sys-devel/clang: arch-type patch merged upstream
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/clang-9999.ebuild3
-rw-r--r--sys-devel/clang/files/9999/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch140
2 files changed, 0 insertions, 143 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 7b793aff3cd9..e179107e2c22 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -103,9 +103,6 @@ src_unpack() {
}
src_prepare() {
- # fix finding compiler-rt libs
- eapply "${FILESDIR}"/9999/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
-
# fix stand-alone doc build
eapply "${FILESDIR}"/9999/0007-cmake-Support-stand-alone-Sphinx-doxygen-doc-build.patch
diff --git a/sys-devel/clang/files/9999/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch b/sys-devel/clang/files/9999/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
deleted file mode 100644
index 6a0278969c09..000000000000
--- a/sys-devel/clang/files/9999/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
+++ /dev/null
@@ -1,140 +0,0 @@
-From 3ebf8771792a40ff7701f1309914d5d3d930ea71 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Thu, 17 Nov 2016 14:19:18 +0100
-Subject: [PATCH] [Driver] Use arch type to find compiler-rt libraries (on
- Linux)
-
-Use llvm::Triple::getArchTypeName() when looking for compiler-rt
-libraries, rather than the exact arch string from the triple. This is
-more correct as it matches the values used when building compiler-rt
-(builtin-config-ix.cmake) which are the subset of the values allowed
-in triples.
-
-For example, this fixes an issue when the compiler set for
-i686-pc-linux-gnu triple would not find an i386 compiler-rt library,
-while this is the exact arch that is detected by compiler-rt. The same
-applies to any other i?86 variant allowed by LLVM.
-
-This also makes the special case for MSVC unnecessary, since now i386
-will be used reliably for all 32-bit x86 variants.
----
- lib/Driver/ToolChain.cpp | 5 +----
- .../usr/i686-unknown-linux/lib/.keep | 0
- .../usr/lib/gcc/i686-unknown-linux/4.6.0/crtbegin.o | 0
- test/Driver/linux-ld.c | 21 +++++++++++++++++++++
- test/Driver/nostdlib.c | 2 +-
- test/Driver/print-libgcc-file-name-clangrt.c | 10 ++++++++--
- test/Driver/windows-cross.c | 2 +-
- 7 files changed, 32 insertions(+), 8 deletions(-)
- create mode 100644 test/Driver/Inputs/basic_linux_tree/usr/i686-unknown-linux/lib/.keep
- create mode 100644 test/Driver/Inputs/basic_linux_tree/usr/lib/gcc/i686-unknown-linux/4.6.0/crtbegin.o
-
-diff --git a/lib/Driver/ToolChain.cpp b/lib/Driver/ToolChain.cpp
-index 0476d156f5..2660c5a2c0 100644
---- a/lib/Driver/ToolChain.cpp
-+++ b/lib/Driver/ToolChain.cpp
-@@ -297,15 +297,12 @@ static StringRef getArchNameForCompilerRTLib(const ToolChain &TC,
- const llvm::Triple &Triple = TC.getTriple();
- bool IsWindows = Triple.isOSWindows();
-
-- if (Triple.isWindowsMSVCEnvironment() && TC.getArch() == llvm::Triple::x86)
-- return "i386";
--
- if (TC.getArch() == llvm::Triple::arm || TC.getArch() == llvm::Triple::armeb)
- return (arm::getARMFloatABI(TC, Args) == arm::FloatABI::Hard && !IsWindows)
- ? "armhf"
- : "arm";
-
-- return TC.getArchName();
-+ return llvm::Triple::getArchTypeName(TC.getArch());
- }
-
- std::string ToolChain::getCompilerRTPath() const {
-diff --git a/test/Driver/Inputs/basic_linux_tree/usr/i686-unknown-linux/lib/.keep b/test/Driver/Inputs/basic_linux_tree/usr/i686-unknown-linux/lib/.keep
-new file mode 100644
-index 0000000000..e69de29bb2
-diff --git a/test/Driver/Inputs/basic_linux_tree/usr/lib/gcc/i686-unknown-linux/4.6.0/crtbegin.o b/test/Driver/Inputs/basic_linux_tree/usr/lib/gcc/i686-unknown-linux/4.6.0/crtbegin.o
-new file mode 100644
-index 0000000000..e69de29bb2
-diff --git a/test/Driver/linux-ld.c b/test/Driver/linux-ld.c
-index 1c5f1a4556..a47afe3924 100644
---- a/test/Driver/linux-ld.c
-+++ b/test/Driver/linux-ld.c
-@@ -71,6 +71,27 @@
- // CHECK-LD-RT: libclang_rt.builtins-x86_64.a"
- //
- // RUN: %clang -no-canonical-prefixes %s -### -o %t.o 2>&1 \
-+// RUN: --target=i686-unknown-linux \
-+// RUN: --gcc-toolchain="" \
-+// RUN: --sysroot=%S/Inputs/basic_linux_tree \
-+// RUN: --rtlib=compiler-rt \
-+// RUN: | FileCheck --check-prefix=CHECK-LD-RT-I686 %s
-+// CHECK-LD-RT-I686-NOT: warning:
-+// CHECK-LD-RT-I686: "{{.*}}ld{{(.exe)?}}" "--sysroot=[[SYSROOT:[^"]+]]"
-+// CHECK-LD-RT-I686: "--eh-frame-hdr"
-+// CHECK-LD-RT-I686: "-m" "elf_i386"
-+// CHECK-LD-RT-I686: "-dynamic-linker"
-+// CHECK-LD-RT-I686: "{{.*}}/usr/lib/gcc/i686-unknown-linux/4.6.0{{/|\\\\}}crtbegin.o"
-+// CHECK-LD-RT-I686: "-L[[SYSROOT]]/usr/lib/gcc/i686-unknown-linux/4.6.0"
-+// CHECK-LD-RT-I686: "-L[[SYSROOT]]/usr/lib/gcc/i686-unknown-linux/4.6.0/../../../../i686-unknown-linux/lib"
-+// CHECK-LD-RT-I686: "-L[[SYSROOT]]/usr/lib/gcc/i686-unknown-linux/4.6.0/../../.."
-+// CHECK-LD-RT-I686: "-L[[SYSROOT]]/lib"
-+// CHECK-LD-RT-I686: "-L[[SYSROOT]]/usr/lib"
-+// CHECK-LD-RT-I686: libclang_rt.builtins-i386.a"
-+// CHECK-LD-RT-I686: "-lc"
-+// CHECK-LD-RT-I686: libclang_rt.builtins-i386.a"
-+//
-+// RUN: %clang -no-canonical-prefixes %s -### -o %t.o 2>&1 \
- // RUN: --target=arm-linux-androideabi \
- // RUN: --gcc-toolchain="" \
- // RUN: --sysroot=%S/Inputs/basic_android_tree/sysroot \
-diff --git a/test/Driver/nostdlib.c b/test/Driver/nostdlib.c
-index a9ef665c57..c9793d968c 100644
---- a/test/Driver/nostdlib.c
-+++ b/test/Driver/nostdlib.c
-@@ -27,5 +27,5 @@
- //
- // CHECK-LINUX-NOSTDLIB: warning: argument unused during compilation: '--rtlib=compiler-rt'
- // CHECK-LINUX-NOSTDLIB: "{{(.*[^.0-9A-Z_a-z])?}}ld{{(.exe)?}}"
--// CHECK-LINUX-NOSTDLIB-NOT: "{{.*}}/Inputs/resource_dir{{/|\\\\}}lib{{/|\\\\}}linux{{/|\\\\}}libclang_rt.builtins-i686.a"
-+// CHECK-LINUX-NOSTDLIB-NOT: "{{.*}}/Inputs/resource_dir{{/|\\\\}}lib{{/|\\\\}}linux{{/|\\\\}}libclang_rt.builtins-i386.a"
- // CHECK-MSVC-NOSTDLIB: warning: argument unused during compilation: '--rtlib=compiler-rt'
-diff --git a/test/Driver/print-libgcc-file-name-clangrt.c b/test/Driver/print-libgcc-file-name-clangrt.c
-index fb4545af30..ce941dc4a1 100644
---- a/test/Driver/print-libgcc-file-name-clangrt.c
-+++ b/test/Driver/print-libgcc-file-name-clangrt.c
-@@ -5,10 +5,16 @@
- // RUN: | FileCheck --check-prefix=CHECK-CLANGRT-X8664 %s
- // CHECK-CLANGRT-X8664: libclang_rt.builtins-x86_64.a
-
-+// RUN: %clang -rtlib=compiler-rt -print-libgcc-file-name 2>&1 \
-+// RUN: --target=i386-pc-linux \
-+// RUN: | FileCheck --check-prefix=CHECK-CLANGRT-I386 %s
-+// CHECK-CLANGRT-I386: libclang_rt.builtins-i386.a
-+
-+// Check whether alternate arch values map to the correct library.
-+//
- // RUN: %clang -rtlib=compiler-rt -print-libgcc-file-name 2>&1 \
- // RUN: --target=i686-pc-linux \
--// RUN: | FileCheck --check-prefix=CHECK-CLANGRT-I686 %s
--// CHECK-CLANGRT-I686: libclang_rt.builtins-i686.a
-+// RUN: | FileCheck --check-prefix=CHECK-CLANGRT-I386 %s
-
- // RUN: %clang -rtlib=compiler-rt -print-libgcc-file-name 2>&1 \
- // RUN: --target=arm-linux-gnueabi \
-diff --git a/test/Driver/windows-cross.c b/test/Driver/windows-cross.c
-index 0e688f0a26..072d37cd51 100644
---- a/test/Driver/windows-cross.c
-+++ b/test/Driver/windows-cross.c
-@@ -64,7 +64,7 @@
- // RUN: | FileCheck %s --check-prefix CHECK-SANITIZE-ADDRESS-EXE-X86
-
- // CHECK-SANITIZE-ADDRESS-EXE-X86: "-fsanitize=address"
--// CHECK-SANITIZE-ADDRESS-EXE-X86: "{{.*}}clang_rt.asan_dynamic-i686.lib" "{{.*}}clang_rt.asan_dynamic_runtime_thunk-i686.lib" "--undefined" "___asan_seh_interceptor"
-+// CHECK-SANITIZE-ADDRESS-EXE-X86: "{{.*}}clang_rt.asan_dynamic-i386.lib" "{{.*}}clang_rt.asan_dynamic_runtime_thunk-i386.lib" "--undefined" "___asan_seh_interceptor"
-
- // RUN: %clang -### -target armv7-windows-itanium --sysroot %S/Inputs/Windows/ARM/8.1 -B %S/Inputs/Windows/ARM/8.1/usr/bin -fuse-ld=lld-link2 -shared -o shared.dll -fsanitize=tsan -x c++ %s 2>&1 \
- // RUN: | FileCheck %s --check-prefix CHECK-SANITIZE-TSAN
---
-2.14.1
-