summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-03-01 15:42:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-03-01 15:43:00 +0000
commitbe40870874711d398762b80ed81c2f3dd7242c58 (patch)
tree1d57add3f0096f4de521012ea6ba917ceb56c794 /sys-fabric
parentnet-misc/turbovnc: drop incompatible init scripts (diff)
downloadgentoo-be40870874711d398762b80ed81c2f3dd7242c58.tar.gz
gentoo-be40870874711d398762b80ed81c2f3dd7242c58.tar.bz2
gentoo-be40870874711d398762b80ed81c2f3dd7242c58.zip
sys-fabric/opensm: Bump
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'sys-fabric')
-rw-r--r--sys-fabric/opensm/Manifest1
-rw-r--r--sys-fabric/opensm/opensm-3.3.23.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-fabric/opensm/Manifest b/sys-fabric/opensm/Manifest
index b3649eecb827..2e1884a41089 100644
--- a/sys-fabric/opensm/Manifest
+++ b/sys-fabric/opensm/Manifest
@@ -1 +1,2 @@
DIST OFED-3.12-rc1.tgz 22055476 BLAKE2B 49e6411721392f418369a292513709f396fbb0f17001687aa15b5c0acdc91013cc67354e5978df56452178af7fbbd338a7ff408592ff9126a3045b9bb27375fe SHA512 9f834d6982ab7e8ab47a8b5c958ab2e4c238ef983e47798e7f06655f69672ea1e996297939b381f26ed8c39552f6e62156173d5ddd2f0a7b6cad6aecdd973944
+DIST opensm-3.3.23.tar.gz 1357906 BLAKE2B 7f085dc1e0a1f284baf1410661aa247ef7e48cdaa696c38ef8a38d5a214e03966b54fb75c035103ac0d6ab9e0a37500d5fad51b0b52c7f5edffb3c3ddfa86eb4 SHA512 249143fcf2cac0504923992d46dfbd6821aad3da55ecc12c92b273b4e59196f88d9d1802d9f58ae6f1ace49958e0222424aea9b48e5aba519e5a5736fc51c3fe
diff --git a/sys-fabric/opensm/opensm-3.3.23.ebuild b/sys-fabric/opensm/opensm-3.3.23.ebuild
new file mode 100644
index 000000000000..ffcf8f39bf14
--- /dev/null
+++ b/sys-fabric/opensm/opensm-3.3.23.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools eutils
+
+HOMEPAGE="https://github.com/linux-rdma/opensm/"
+DESCRIPTION="OpenSM - InfiniBand Subnet Manager and Administration for OpenIB"
+
+SRC_URI="https://github.com/linux-rdma/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="tools"
+SLOT="0"
+LICENSE="|| ( GPL-2 BSD-2 )"
+
+DEPEND="sys-cluster/rdma-core"
+RDEPEND="$DEPEND
+ tools? (
+ net-misc/iputils
+ net-misc/openssh
+ )"
+
+PATCHES=( "${FILESDIR}/${PN}-3.3.17-sldd.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-perf-mgr \
+ --enable-default-event-plugin \
+ --with-osmv="openib"
+}
+
+src_install() {
+ default
+ newconfd "${FILESDIR}/opensm.conf.d" opensm
+ newinitd "${FILESDIR}/opensm.init.d" opensm
+ insinto /etc/logrotate.d
+ newins "${S}/scripts/opensm.logrotate" opensm
+ # we dont need this int script
+ rm "${ED}/etc/init.d/opensmd" || die "Dropping of upstream initscript failed"
+
+ if use tools; then
+ dosbin scripts/sldd.sh
+ newconfd "${FILESDIR}/sldd.conf.d" sldd
+ newinitd "${FILESDIR}/sldd.init.d" sldd
+ fi
+}
+
+pkg_postinst() {
+ einfo "To automatically configure the infiniband subnet manager on boot,"
+ einfo "edit /etc/opensm.conf and add opensm to your start-up scripts:"
+ einfo "\`rc-update add opensm default\`"
+}