summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-16 00:23:31 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-16 00:23:31 +0100
commite33ca0f6b29eb486f137e70f371b9571e151a8ff (patch)
treea06539567ba52e1b94757e33dc922f80b200634a /sys-fabric
parentsys-cluster/libqb: disable static libs (diff)
downloadgentoo-e33ca0f6b29eb486f137e70f371b9571e151a8ff.tar.gz
gentoo-e33ca0f6b29eb486f137e70f371b9571e151a8ff.tar.bz2
gentoo-e33ca0f6b29eb486f137e70f371b9571e151a8ff.zip
sys-fabric/libmlx5: disable static libs and Werror
Closes: https://bugs.gentoo.org/686100 Closes: https://bugs.gentoo.org/732220 Closes: https://github.com/gentoo/gentoo/pull/18272 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-fabric')
-rw-r--r--sys-fabric/libmlx5/libmlx5-1.0.1.ebuild27
1 files changed, 19 insertions, 8 deletions
diff --git a/sys-fabric/libmlx5/libmlx5-1.0.1.ebuild b/sys-fabric/libmlx5/libmlx5-1.0.1.ebuild
index 4b7a5b45ba86..52884509e40b 100644
--- a/sys-fabric/libmlx5/libmlx5-1.0.1.ebuild
+++ b/sys-fabric/libmlx5/libmlx5-1.0.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
OFED_VER="3.12"
OFED_RC="1"
@@ -12,11 +12,22 @@ inherit openib
DESCRIPTION="OpenIB userspace driver for Mellanox ConnectIB HCA"
KEYWORDS="amd64 ~x86 ~amd64-linux"
-IUSE=""
-DEPEND="
- sys-fabric/libibverbs:${SLOT}
- "
-RDEPEND="
- !sys-fabric/openib-userspace"
+DEPEND="sys-fabric/libibverbs:${SLOT}"
+RDEPEND="!sys-fabric/openib-userspace"
block_other_ofed_versions
+
+src_prepare() {
+ default
+
+ sed -i -e '/CFLAGS=\"$CFLAGS -Werror\"/d' configure || die
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}