summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-firmware/nvidia-firmware/nvidia-firmware-340.32.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-firmware/nvidia-firmware/nvidia-firmware-340.32.ebuild')
-rw-r--r--sys-firmware/nvidia-firmware/nvidia-firmware-340.32.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-firmware/nvidia-firmware/nvidia-firmware-340.32.ebuild b/sys-firmware/nvidia-firmware/nvidia-firmware-340.32.ebuild
new file mode 100644
index 000000000000..3972aaf95dc8
--- /dev/null
+++ b/sys-firmware/nvidia-firmware/nvidia-firmware-340.32.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1 unpacker
+
+NV_URI="http://us.download.nvidia.com/XFree86/"
+X86_NV_PACKAGE="NVIDIA-Linux-x86-${PV}"
+
+EXTRACT_FIRMWARE_REV="96641bfebb2547402b2145fcf0e3116410f0da87"
+
+DESCRIPTION="Kernel and mesa firmware for nouveau (video accel and pgraph)"
+HOMEPAGE="http://nouveau.freedesktop.org/wiki/VideoAcceleration/"
+SRC_URI="${NV_URI}Linux-x86/${PV}/${X86_NV_PACKAGE}.run
+ https://raw.github.com/imirkin/re-vp2/${EXTRACT_FIRMWARE_REV}/extract_firmware.py -> nvidia_extract_firmware-${PV}.py"
+
+LICENSE="MIT NVIDIA-r2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND=""
+
+RESTRICT="bindist mirror"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ mkdir "${S}/${X86_NV_PACKAGE}"
+ cd "${S}/${X86_NV_PACKAGE}"
+ unpack_makeself "${X86_NV_PACKAGE}.run"
+}
+
+src_compile() {
+ "${PYTHON}" "${DISTDIR}"/nvidia_extract_firmware-${PV}.py || die "Extracting firmwares failed..."
+}
+
+src_install() {
+ insinto /lib/firmware/nouveau
+ doins nv* vuc-*
+}