summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-02-07 10:44:14 +0100
committerAaron Bauman <bman@gentoo.org>2019-02-09 14:54:57 -0500
commita0afa8172431e6ef851f964e11aa68463c1e0262 (patch)
treeb02c284132d0e0825d3c53c36e11ae5e63095a19 /sys-firmware/sgabios
parentnet-dns/dnrd: remove old (EAPI0) (diff)
downloadgentoo-a0afa8172431e6ef851f964e11aa68463c1e0262.tar.gz
gentoo-a0afa8172431e6ef851f964e11aa68463c1e0262.tar.bz2
gentoo-a0afa8172431e6ef851f964e11aa68463c1e0262.zip
sys-firmware/sgabios: remove old (EAPI4)
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10998 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'sys-firmware/sgabios')
-rw-r--r--sys-firmware/sgabios/sgabios-0.1_pre8.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild b/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild
deleted file mode 100644
index b062b9588e3c..000000000000
--- a/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="serial graphics adapter bios option rom for x86"
-HOMEPAGE="https://code.google.com/p/sgabios/"
-SRC_URI="mirror://gentoo/${P}.tar.xz
- https://dev.gentoo.org/~cardoe/distfiles/${P}.tar.xz
- https://dev.gentoo.org/~cardoe/distfiles/${P}-bins.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86"
-IUSE=""
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
- epatch "${FILESDIR}"/${P}-build-cc.patch #552280
- epatch_user
-}
-
-src_compile() {
- if use amd64 || use x86 ; then
- tc-ld-disable-gold
- tc-export_build_env BUILD_CC
- emake \
- BUILD_CC="${BUILD_CC}" \
- BUILD_CFLAGS="${BUILD_CFLAGS}" \
- BUILD_LDFLAGS="${BUILD_LDFLAGS}" \
- BUILD_CPPFLAGS="${BUILD_CPPFLAGS}" \
- CC="$(tc-getCC)" \
- LD="$(tc-getLD)" \
- AR="$(tc-getAR)" \
- OBJCOPY="$(tc-getOBJCOPY)"
- fi
-}
-
-src_install() {
- insinto /usr/share/sgabios
-
- if use amd64 || use x86 ; then
- doins sgabios.bin
- else
- doins bins/sgabios.bin
- fi
-}