summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-firmware/zd1201-firmware
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-firmware/zd1201-firmware')
-rw-r--r--sys-firmware/zd1201-firmware/Manifest1
-rw-r--r--sys-firmware/zd1201-firmware/metadata.xml10
-rw-r--r--sys-firmware/zd1201-firmware/zd1201-firmware-0.14.ebuild26
3 files changed, 37 insertions, 0 deletions
diff --git a/sys-firmware/zd1201-firmware/Manifest b/sys-firmware/zd1201-firmware/Manifest
new file mode 100644
index 000000000000..f5ef35194941
--- /dev/null
+++ b/sys-firmware/zd1201-firmware/Manifest
@@ -0,0 +1 @@
+DIST zd1201-0.14-fw.tar.gz 86538 SHA256 56fd11578b0fc13947786fca0e1b4227f04b0f00cf190fd3d3bc4dd005ba4267 SHA512 4143966d386029d50b0cf54bb40f0636daac8f4696782f2cd7ec8924b80ed5d889b373817c662000fbbc8010d4bc81864d2381dd7e2242bf9cee0e0fb9d56fe9 WHIRLPOOL 14107b3469e7f84f934032e333351c17122e575a22fb0f131696a9dcbdb356f2cda04d143645e7a5f73f606491147350829d1938680ffdd90bf42af9b6ea31e6
diff --git a/sys-firmware/zd1201-firmware/metadata.xml b/sys-firmware/zd1201-firmware/metadata.xml
new file mode 100644
index 000000000000..26724dc23aa5
--- /dev/null
+++ b/sys-firmware/zd1201-firmware/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">linux-lc100020</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-firmware/zd1201-firmware/zd1201-firmware-0.14.ebuild b/sys-firmware/zd1201-firmware/zd1201-firmware-0.14.ebuild
new file mode 100644
index 000000000000..2e75a98664d2
--- /dev/null
+++ b/sys-firmware/zd1201-firmware/zd1201-firmware-0.14.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=zd1201-${PV}-fw
+
+DESCRIPTION="Firmware for ZyDAS 1201 based USB 802.11b Network WiFi devices"
+HOMEPAGE="http://linux-lc100020.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linux-lc100020/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-3 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() { :; }
+
+src_install() {
+ insinto /lib/firmware
+ doins zd1201{,-ap}.fw
+ dodoc README
+}