summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuta Satoh <nigoro.dev@gmail.com>2016-10-11 21:37:39 +0900
committerAlexis Ballier <aballier@gentoo.org>2016-10-11 16:47:48 +0200
commite1bd456fcf9272cfdeaf542618c6b1f3ce3d1118 (patch)
tree6eb8e704f2281853b01e1abcd5770ad59d798e86 /sys-freebsd/freebsd-cddl/files
parenteclass/freebsd.eclass: added FreeBSD 11.0 support. (diff)
downloadgentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.tar.gz
gentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.tar.bz2
gentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.zip
sys-freebsd: bump to 11.0
Diffstat (limited to 'sys-freebsd/freebsd-cddl/files')
-rw-r--r--sys-freebsd/freebsd-cddl/files/freebsd-cddl-11.0-add-libs.patch87
-rw-r--r--sys-freebsd/freebsd-cddl/files/freebsd-cddl-11.0-workaround.patch12
2 files changed, 99 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-cddl/files/freebsd-cddl-11.0-add-libs.patch b/sys-freebsd/freebsd-cddl/files/freebsd-cddl-11.0-add-libs.patch
new file mode 100644
index 000000000000..46f25217bdac
--- /dev/null
+++ b/sys-freebsd/freebsd-cddl/files/freebsd-cddl-11.0-add-libs.patch
@@ -0,0 +1,87 @@
+diff --git a/cddl/sbin/zfs/Makefile b/cddl/sbin/zfs/Makefile
+index 1e386e5..a4c08ee 100644
+--- a/cddl/sbin/zfs/Makefile
++++ b/cddl/sbin/zfs/Makefile
+@@ -22,6 +22,6 @@ CFLAGS+= -I${.CURDIR}/../../../sys/cddl/contrib/opensolaris/uts/common/fs/zfs
+ CFLAGS+= -I${.CURDIR}/../../../sys/cddl/contrib/opensolaris/uts/common/sys
+ CFLAGS+= -I${.CURDIR}/../../../sys/cddl/contrib/opensolaris/common/zfs
+
+-LIBADD= jail nvpair uutil zfs_core zfs
++LIBADD= jail nvpair uutil zfs_core zfs umem avl
+
+ .include <bsd.prog.mk>
+diff --git a/cddl/sbin/zpool/Makefile b/cddl/sbin/zpool/Makefile
+index ebf0f90..c70a3c4 100644
+--- a/cddl/sbin/zpool/Makefile
++++ b/cddl/sbin/zpool/Makefile
+@@ -27,6 +27,6 @@ CFLAGS+= -I${.CURDIR}/../../../sys/cddl/contrib/opensolaris/uts/common/sys
+ CFLAGS+= -I${.CURDIR}/../../../cddl/contrib/opensolaris/lib/libzpool/common
+ CFLAGS+= -I${.CURDIR}/../../../cddl/contrib/opensolaris/cmd/stat/common
+
+-LIBADD= geom nvpair uutil zfs
++LIBADD= geom nvpair uutil zfs umem avl zfs_core
+
+ .include <bsd.prog.mk>
+diff --git a/cddl/usr.sbin/lockstat/Makefile b/cddl/usr.sbin/lockstat/Makefile
+index fc68904..9af6ff2 100644
+--- a/cddl/usr.sbin/lockstat/Makefile
++++ b/cddl/usr.sbin/lockstat/Makefile
+@@ -21,6 +21,6 @@ CFLAGS+= -DNEED_ERRLOC -g
+
+ #YFLAGS+= -d
+
+-LIBADD= elf dtrace rt
++LIBADD= elf dtrace rt ctf
+
+ .include <bsd.prog.mk>
+diff --git a/cddl/usr.sbin/plockstat/Makefile b/cddl/usr.sbin/plockstat/Makefile
+index 77b6139..7737efd 100644
+--- a/cddl/usr.sbin/plockstat/Makefile
++++ b/cddl/usr.sbin/plockstat/Makefile
+@@ -18,6 +18,6 @@ CFLAGS+= -I${.CURDIR}/../../../sys/cddl/compat/opensolaris \
+ -I${.CURDIR}/../../../cddl/lib/libdtrace \
+ -I${.CURDIR}/../../../sys
+
+-LIBADD= dtrace proc
++LIBADD= dtrace proc ctf
+
+ .include <bsd.prog.mk>
+diff --git a/cddl/usr.sbin/zdb/Makefile b/cddl/usr.sbin/zdb/Makefile
+index 3609502..71526f7 100644
+--- a/cddl/usr.sbin/zdb/Makefile
++++ b/cddl/usr.sbin/zdb/Makefile
+@@ -24,7 +24,7 @@ CFLAGS+= -I${.CURDIR}/../../../sys/cddl/contrib/opensolaris/common/zfs
+ CFLAGS+= -I${.CURDIR}/../../../cddl/contrib/opensolaris/head
+ CFLAGS+= -I${.CURDIR}/../../lib/libumem
+
+-LIBADD= nvpair umem uutil zfs zpool
++LIBADD= nvpair umem uutil zfs zpool avl zfs_core
+
+ # Since there are many asserts in this program, it makes no sense to compile
+ # it without debugging.
+diff --git a/cddl/usr.sbin/zfsd/Makefile.common b/cddl/usr.sbin/zfsd/Makefile.common
+index a545609..034d418 100644
+--- a/cddl/usr.sbin/zfsd/Makefile.common
++++ b/cddl/usr.sbin/zfsd/Makefile.common
+@@ -35,7 +35,7 @@ CXXFLAGS= -g -DNEED_SOLARIS_BOOLEAN ${INCFLAGS}
+
+ DPADD= ${LIBDEVDCTL} ${LIBZFS} ${LIBZFS_CORE} ${LIBUTIL} ${LIBGEOM} \
+ ${LIBBSDXML} ${LIBSBUF} ${LIBNVPAIR} ${LIBUUTIL}
+-LIBADD= devdctl zfs zfs_core util geom bsdxml sbuf nvpair uutil
++LIBADD= devdctl zfs zfs_core util geom bsdxml sbuf nvpair uutil umem avl
+
+ cscope:
+ find ${.CURDIR} -type f -a \( -name "*.[ch]" -o -name "*.cc" \) \
+diff --git a/cddl/usr.sbin/zhack/Makefile b/cddl/usr.sbin/zhack/Makefile
+index 02c51ac..d9b79a9 100644
+--- a/cddl/usr.sbin/zhack/Makefile
++++ b/cddl/usr.sbin/zhack/Makefile
+@@ -23,7 +23,7 @@ CFLAGS+= -I${.CURDIR}/../../../sys/cddl/contrib/opensolaris/common/zfs
+ CFLAGS+= -I${.CURDIR}/../../../cddl/contrib/opensolaris/head
+ CFLAGS+= -I${.CURDIR}/../../lib/libumem
+
+-LIBADD= nvpair zfs zpool
++LIBADD= nvpair zfs zpool umem uutil avl zfs_core
+
+ CFLAGS+= -DDEBUG=1
+ #DEBUG_FLAGS+= -g
diff --git a/sys-freebsd/freebsd-cddl/files/freebsd-cddl-11.0-workaround.patch b/sys-freebsd/freebsd-cddl/files/freebsd-cddl-11.0-workaround.patch
new file mode 100644
index 000000000000..839b6b5a7924
--- /dev/null
+++ b/sys-freebsd/freebsd-cddl/files/freebsd-cddl-11.0-workaround.patch
@@ -0,0 +1,12 @@
+diff --git a/cddl/usr.sbin/zfsd/Makefile.common b/cddl/usr.sbin/zfsd/Makefile.common
+index 6c71bdf..6b71908 100644
+--- a/cddl/usr.sbin/zfsd/Makefile.common
++++ b/cddl/usr.sbin/zfsd/Makefile.common
+@@ -31,6 +31,7 @@ INCFLAGS+= -I${SRCDIR}/sys/cddl/contrib/opensolaris/uts/common/fs/zfs
+ INCFLAGS+= -I${SRCDIR}/sys/cddl/contrib/opensolaris/uts/common/sys
+
+ CFLAGS= -g -DNEED_SOLARIS_BOOLEAN ${INCFLAGS}
++CXXFLAGS= -g -DNEED_SOLARIS_BOOLEAN ${INCFLAGS}
+
+ DPADD= ${LIBDEVDCTL} ${LIBZFS} ${LIBZFS_CORE} ${LIBUTIL} ${LIBGEOM} \
+ ${LIBBSDXML} ${LIBSBUF} ${LIBNVPAIR} ${LIBUUTIL}