summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-01 10:28:00 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-01 11:06:53 +0100
commit5ddc0c15d8941afd7654b9e96b2f803d330e928f (patch)
treece2b8c83ae2bd168ac366c1a7dcbb750a648207b /sys-freebsd/freebsd-lib
parentsys-freebsd/freebsd-lib: add :0= dep on openssl (diff)
downloadgentoo-5ddc0c15d8941afd7654b9e96b2f803d330e928f.tar.gz
gentoo-5ddc0c15d8941afd7654b9e96b2f803d330e928f.tar.bz2
gentoo-5ddc0c15d8941afd7654b9e96b2f803d330e928f.zip
sys-freebsd/freebsd-lib: move GNU install/sed fixes before USE=build check so that they are applied also with USE=build.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sys-freebsd/freebsd-lib')
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-10.2-r2.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-10.2-r2.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-10.2-r2.ebuild
index 49e8c0bf8a9e..d50c0d407df7 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-10.2-r2.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-10.2-r2.ebuild
@@ -186,6 +186,19 @@ src_prepare() {
sed -e 's/LDFLAGS/RAW_LDFLAGS/g' \
-i "${S}/csu/i386-elf/Makefile" \
-i "${S}/csu/ia64/Makefile" || die
+
+ if install --version 2> /dev/null | grep -q GNU; then
+ sed -i.bak -e 's:${INSTALL} -C:${INSTALL}:' "${WORKDIR}/include/Makefile"
+ fi
+
+ # Try to fix sed calls for GNU sed. Do it only with GNU userland and force
+ # BSD's sed on BSD.
+ cd "${S}"
+ if [[ ${CBUILD:-${CHOST}} != *bsd* ]]; then
+ find . -name Makefile -exec sed -ibak 's/sed -i /sed -i/' {} \;
+ sed -i -e 's/-i ""/-i""/' "${S}/csu/Makefile.inc" || die
+ fi
+
if use build; then
cd "${WORKDIR}"
# This patch has to be applied on ${WORKDIR}/sys, so we do it here since it
@@ -204,18 +217,6 @@ src_prepare() {
"${S}/libc/rpc/Makefile.inc" \
"${S}/libc/yp/Makefile.inc"
fi
-
- if install --version 2> /dev/null | grep -q GNU; then
- sed -i.bak -e 's:${INSTALL} -C:${INSTALL}:' "${WORKDIR}/include/Makefile"
- fi
-
- # Try to fix sed calls for GNU sed. Do it only with GNU userland and force
- # BSD's sed on BSD.
- cd "${S}"
- if [[ ${CBUILD:-${CHOST}} != *bsd* ]]; then
- find . -name Makefile -exec sed -ibak 's/sed -i /sed -i/' {} \;
- sed -i -e 's/-i ""/-i""/' "${S}/csu/Makefile.inc" || die
- fi
}
bootstrap_lib() {