summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuta Satoh <nigoro.dev@gmail.com>2016-08-15 21:23:22 +0900
committerPatrice Clement <monsieurp@gentoo.org>2016-08-15 22:55:14 +0200
commit7c1b45db1cc33fdfb2d018e46d1f1a5afb5378b2 (patch)
tree4f953cee87ee33ab8acefa01bbdef9648ab5f6cc /sys-freebsd/freebsd-libexec
parentmedia-video/mpv: remove old (diff)
downloadgentoo-7c1b45db1cc33fdfb2d018e46d1f1a5afb5378b2.tar.gz
gentoo-7c1b45db1cc33fdfb2d018e46d1f1a5afb5378b2.tar.bz2
gentoo-7c1b45db1cc33fdfb2d018e46d1f1a5afb5378b2.zip
sys-freebsd/freebsd-libexec: Added some define for upgrade.
Closes: https://github.com/gentoo/gentoo/pull/2083 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'sys-freebsd/freebsd-libexec')
-rw-r--r--sys-freebsd/freebsd-libexec/freebsd-libexec-10.3.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-libexec/freebsd-libexec-10.3.ebuild b/sys-freebsd/freebsd-libexec/freebsd-libexec-10.3.ebuild
index 84eb83925376..26851c8299e5 100644
--- a/sys-freebsd/freebsd-libexec/freebsd-libexec-10.3.ebuild
+++ b/sys-freebsd/freebsd-libexec/freebsd-libexec-10.3.ebuild
@@ -72,6 +72,9 @@ src_prepare() {
# taken from sys/sys/cdefs.h
echo '#define __compiler_membar() __asm __volatile(" " : : : "memory")' >> "${S}"/rtld-elf/rtld.h
# taken from sys/sys/mman.h
+ echo '#define MAP_ALIGNED(n) ((n) << MAP_ALIGNMENT_SHIFT)' >> "${S}"/rtld-elf/rtld.h
+ echo '#define MAP_ALIGNMENT_SHIFT 24' >> "${S}"/rtld-elf/rtld.h
+ echo '#define MAP_ALIGNMENT_MASK MAP_ALIGNED(0xff)' >> "${S}"/rtld-elf/rtld.h
echo '#define MAP_ALIGNED_SUPER MAP_ALIGNED(1)' >> "${S}"/rtld-elf/rtld.h
fi
}