summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-25 21:51:34 -0400
committerSam James <sam@gentoo.org>2024-03-26 12:27:30 +0000
commit69aa918261ef89f1ab56ef61d4e839d7ab27ac13 (patch)
tree4d7886ccdd52745c3aa40f464c8cc52a53549319 /sys-fs/aufs-util
parentsys-fs/aufs-util: do not perform all compilation during src_install (diff)
downloadgentoo-69aa918261ef89f1ab56ef61d4e839d7ab27ac13.tar.gz
gentoo-69aa918261ef89f1ab56ef61d4e839d7ab27ac13.tar.bz2
gentoo-69aa918261ef89f1ab56ef61d4e839d7ab27ac13.zip
sys-fs/aufs-util: mark as LTO-unsafe
It uses an elaborate macro to insert __attribute__ ((section ("EXP"), used)) as an export annotation, and then uses readelf to dump this and assemble a linker version script. Apparently visibility attributes is too boring. ;) It totally falls over when exposed to LTO. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/aufs-util')
-rw-r--r--sys-fs/aufs-util/aufs-util-4.14_p20190603.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-fs/aufs-util/aufs-util-4.14_p20190603.ebuild b/sys-fs/aufs-util/aufs-util-4.14_p20190603.ebuild
index 2055f81c8d3a..ced94344056b 100644
--- a/sys-fs/aufs-util/aufs-util-4.14_p20190603.ebuild
+++ b/sys-fs/aufs-util/aufs-util-4.14_p20190603.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit linux-info multilib toolchain-funcs
+inherit flag-o-matic linux-info multilib toolchain-funcs
DESCRIPTION="Utilities are always necessary for aufs"
HOMEPAGE="http://aufs.sourceforge.net/"
@@ -47,5 +47,12 @@ src_prepare() {
}
src_compile() {
+ # It uses an elaborate macro to insert __attribute__ ((section ("EXP"), used))
+ # as an export annotation, and then uses readelf to dump this and assemble a
+ # linker version script. Apparently visibility attributes is too boring. ;)
+ #
+ # It totally falls over when exposed to LTO.
+ filter-lto
+
emake all
}