summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-29 14:31:09 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-29 14:32:13 -0500
commitf4ab01f44f5966a45b3dc3ea581d742a67cd8973 (patch)
treefecb665d64a69374b607de4687ffe25a3b7b2ddf /sys-fs/clamfs
parentys-power/powerman: remove powerman-2.3.9 (diff)
downloadgentoo-f4ab01f44f5966a45b3dc3ea581d742a67cd8973.tar.gz
gentoo-f4ab01f44f5966a45b3dc3ea581d742a67cd8973.tar.bz2
gentoo-f4ab01f44f5966a45b3dc3ea581d742a67cd8973.zip
sys-fs/clamfs: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Also bump to EAPI=6 Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-fs/clamfs')
-rw-r--r--sys-fs/clamfs/clamfs-1.0.1-r2.ebuild43
-rw-r--r--sys-fs/clamfs/files/clamfs.initd4
2 files changed, 45 insertions, 2 deletions
diff --git a/sys-fs/clamfs/clamfs-1.0.1-r2.ebuild b/sys-fs/clamfs/clamfs-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..dcab6b1fd40e
--- /dev/null
+++ b/sys-fs/clamfs/clamfs-1.0.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+inherit eutils linux-info
+
+DESCRIPTION="A FUSE-based user-space file system with on-access anti-virus file scanning"
+HOMEPAGE="http://clamfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.33
+ sys-fs/fuse
+ dev-cpp/commoncpp2
+ dev-libs/rlog
+ dev-libs/poco"
+RDEPEND="${DEPEND}
+ app-antivirus/clamav"
+
+CONFIG_CHECK="~FUSE_FS"
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-gentoo.patch"
+ eapply -p0 "${FILESDIR}/${P}-gcc45.patch"
+ eapply_user
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ insinto /etc/clamfs
+ doins doc/clamfs.xml
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/sys-fs/clamfs/files/clamfs.initd b/sys-fs/clamfs/files/clamfs.initd
index d7f911ee2b62..1f2440a8f36d 100644
--- a/sys-fs/clamfs/files/clamfs.initd
+++ b/sys-fs/clamfs/files/clamfs.initd
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2010 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$