summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-09-05 20:10:27 +1200
committerJoonas Niilola <juippis@gentoo.org>2020-09-06 08:55:16 +0300
commit73b8e835c9aa62a995f154620d6f7cebfdc7f2d3 (patch)
treeccc451692ab2d3ad5512be395dcd37ddc0274cdc /sys-fs/compsize/compsize-1.3.ebuild
parentsys-fs/compsize: add proxy maintainer (diff)
downloadgentoo-73b8e835c9aa62a995f154620d6f7cebfdc7f2d3.tar.gz
gentoo-73b8e835c9aa62a995f154620d6f7cebfdc7f2d3.tar.bz2
gentoo-73b8e835c9aa62a995f154620d6f7cebfdc7f2d3.zip
sys-fs/compsize: bump to 1.3
Closes: https://bugs.gentoo.org/689144 Package-Manager: Portage-3.0.4-r1, Repoman-3.0.1 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs/compsize/compsize-1.3.ebuild')
-rw-r--r--sys-fs/compsize/compsize-1.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-fs/compsize/compsize-1.3.ebuild b/sys-fs/compsize/compsize-1.3.ebuild
new file mode 100644
index 000000000000..df2657574f74
--- /dev/null
+++ b/sys-fs/compsize/compsize-1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Utility to find btrfs compression type/ratio on a file or set of files"
+HOMEPAGE="https://github.com/kilobyte/compsize"
+
+if [[ ${PV} = 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kilobyte/compsize.git"
+else
+ SRC_URI="https://github.com/kilobyte/compsize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+IUSE="debug"
+SLOT="0"
+
+DEPEND="sys-fs/btrfs-progs"
+
+src_prepare() {
+ default
+ # Don't try to install a gzipped manfile during emake install
+ sed -i -e $'s/\.gz//' -e $'s/gzip.*/install \-Dm755 \$\< \$\@/' Makefile || die
+}
+
+src_configure() {
+ # Used in upstream Makefile, but clobbered by portage's CFLAGS
+ append-cflags -Wall -std=gnu90
+ use debug && append-cflags -DDEBUG -g
+ default
+}
+
+src_install() {
+ emake PREFIX="${D}" install
+ dodoc "README.md"
+}