summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:40:18 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:47 +0100
commitf2d37a4cea7426fc4ddd34e8325e0e542bf6eba6 (patch)
treef156894e3e7aa8d371765f6f031af1897a0dc550 /sys-fs/cryptmount
parentsys-fs/cryptmount: update EAPI 7 -> 8 (diff)
downloadgentoo-f2d37a4cea7426fc4ddd34e8325e0e542bf6eba6.tar.gz
gentoo-f2d37a4cea7426fc4ddd34e8325e0e542bf6eba6.tar.bz2
gentoo-f2d37a4cea7426fc4ddd34e8325e0e542bf6eba6.zip
sys-fs/cryptmount: drop 5.3.3
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-fs/cryptmount')
-rw-r--r--sys-fs/cryptmount/cryptmount-5.3.3.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/sys-fs/cryptmount/cryptmount-5.3.3.ebuild b/sys-fs/cryptmount/cryptmount-5.3.3.ebuild
deleted file mode 100644
index 51ac0e120a86..000000000000
--- a/sys-fs/cryptmount/cryptmount-5.3.3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info
-
-DESCRIPTION="A utility for management and user-mode mounting of encrypted filesystems"
-HOMEPAGE="http://cryptmount.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="argv0switch cswap fsck +gcrypt +largefile mount +nls +luks +openssl selinux systemd udev"
-REQUIRED_USE="
- luks? ( gcrypt )
- openssl? ( gcrypt )
-"
-
-RDEPEND="
- gcrypt? ( dev-libs/libgcrypt:0= )
- luks? ( sys-fs/cryptsetup )
- openssl? ( dev-libs/openssl:0= )
- systemd? ( sys-apps/systemd )
- udev? ( virtual/udev )
- virtual/libiconv
- virtual/libintl
-"
-
-DEPEND="
- ${RDEPEND}
- sys-kernel/linux-headers
-"
-
-BDEPEND="nls? ( sys-devel/gettext )"
-
-DOCS=( "AUTHORS" "ChangeLog" "NEWS" "README" "README.sshfs" "RELNOTES" "ToDo" )
-
-CONFIG_CHECK="BLK_DEV_DM"
-ERROR_BLK_DEV_DM="
- Please enable Device Mapper support in your kernel config
- -> Device Drivers
- -> Multiple devices driver support (RAID and LVM)
- -> Multiple devices driver support (RAID and LVM)
- <*>/<M> Device mapper support
-"
-
-src_prepare() {
- default
-
- # Since SELinux is hardcoded, remove it on disabled SELinux profile
- if ! use selinux; then
- sed -e '/selinux/d' -i dmutils.c || die
- fi
-}
-
-src_configure() {
- local myeconf=(
- --disable-rpath
- $(use_enable argv0switch)
- $(use_enable cswap)
- $(use_enable fsck)
- $(use_with gcrypt libgcrypt)
- $(use_enable largefile)
- $(use_enable mount delegation)
- $(use_enable nls)
- $(use_enable luks)
- $(use_enable openssl openssl-compat)
- $(use_with systemd)
- $(use_enable udev libudev)
-
- )
-
- econf "${myeconf[@]}"
-}