summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2016-04-15 14:55:50 +0200
committerAndreas Schuerch <nativemad@gentoo.org>2016-04-15 14:55:50 +0200
commit836791a9f3ebbbe071cb96aa57c17661f85ba95a (patch)
tree3bfd701b5428398c0837bc828ecb4a39cb398e60 /sys-fs/dislocker/dislocker-0.6.1.ebuild
parentnet-firewall/fwbuilder: add missing qt slot (diff)
downloadgentoo-836791a9f3ebbbe071cb96aa57c17661f85ba95a.tar.gz
gentoo-836791a9f3ebbbe071cb96aa57c17661f85ba95a.tar.bz2
gentoo-836791a9f3ebbbe071cb96aa57c17661f85ba95a.zip
sys-fs/dislocker: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-fs/dislocker/dislocker-0.6.1.ebuild')
-rw-r--r--sys-fs/dislocker/dislocker-0.6.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-fs/dislocker/dislocker-0.6.1.ebuild b/sys-fs/dislocker/dislocker-0.6.1.ebuild
new file mode 100644
index 000000000000..e4497f2fa087
--- /dev/null
+++ b/sys-fs/dislocker/dislocker-0.6.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils flag-o-matic
+
+DESCRIPTION="Dislocker is used to read BitLocker encrypted partitions."
+HOMEPAGE="https://github.com/Aorimn/dislocker"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Aorimn/dislocker.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Aorimn/dislocker/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ruby"
+
+DEPEND="sys-fs/fuse
+ || ( net-libs/polarssl net-libs/mbedtls )
+ ruby? ( dev-lang/ruby:2.1 )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+# We either need to change Werror to Wno-error or remove the multiple declarations of FORTIFY_SOURCE
+# sed 's:Werror:Wno-error:g' -i "${S}/src/CMakeLists.txt" || die
+ sed 's:-D_FORTIFY_SOURCE=2::g' -i "${S}/src/CMakeLists.txt" || die
+
+ sed 's:\.\./man:'../../${P}/man':g' -i "${S}/src/CMakeLists.txt" || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_find_package ruby Ruby)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ find "${S}/man/linux" -name '*.1' -exec doman '{}' +
+ cmake-utils_src_install
+}