summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2020-07-27 16:49:08 +0200
committerAndreas Schuerch <nativemad@gentoo.org>2020-07-27 16:50:09 +0200
commit4f2c7c42c3b24c86fcb599e0f2933d2ab7a64245 (patch)
treeacc30e097e8639e667c1f49ca65632e533defaab /sys-fs/dislocker/dislocker-9999.ebuild
parentwww-client/opera-developer: Version 71.0.3763.0 (diff)
downloadgentoo-4f2c7c42c3b24c86fcb599e0f2933d2ab7a64245.tar.gz
gentoo-4f2c7c42c3b24c86fcb599e0f2933d2ab7a64245.tar.bz2
gentoo-4f2c7c42c3b24c86fcb599e0f2933d2ab7a64245.zip
sys-fs/dislocker: various fixes, bug 700784 & 732204
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Schuerch <nativemad@gentoo.org>
Diffstat (limited to 'sys-fs/dislocker/dislocker-9999.ebuild')
-rw-r--r--sys-fs/dislocker/dislocker-9999.ebuild25
1 files changed, 18 insertions, 7 deletions
diff --git a/sys-fs/dislocker/dislocker-9999.ebuild b/sys-fs/dislocker/dislocker-9999.ebuild
index 08e0e54087af..a15c39558ddc 100644
--- a/sys-fs/dislocker/dislocker-9999.ebuild
+++ b/sys-fs/dislocker/dislocker-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils flag-o-matic
+inherit cmake flag-o-matic
DESCRIPTION="Dislocker is used to read BitLocker encrypted partitions."
HOMEPAGE="https://github.com/Aorimn/dislocker"
@@ -27,24 +27,35 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+CMAKE_REMOVE_MODULES_LIST="${CMAKE_REMOVE_MODULES_LIST} FindRuby"
+
src_prepare() {
- cmake-utils_src_prepare
+ if use ruby && [[ ${PV} == "0.7.1" ]]; then
+ PATCHES=( "${FILESDIR}/${P}-fix-find-ruby.patch" )
+ fi
+ cmake_src_prepare
# We either need to change Werror to Wno-error or remove the multiple declarations of FORTIFY_SOURCE
# sed 's:Werror:Wno-error:g' -i "${S}/src/CMakeLists.txt" || die
sed 's:-D_FORTIFY_SOURCE=2::g' -i "${S}/src/CMakeLists.txt" || die
- sed 's:\.\./man:'../../${P}/man':g' -i "${S}/src/CMakeLists.txt" || die
+# sed 's:\.\./man:'../../${P}/man':g' -i "${S}/src/CMakeLists.txt" || die
+# Do not process compressed versions of the manuals
+ sed -r 's:( create_symlink \$\{BIN_FUSE\}\.1)\.gz (.+\.1)\.gz\\:\1 \2\\:' -i "${S}/src/CMakeLists.txt" || die
+ sed -r 's:^(.+\.1\.gz):#\1:' -i "${S}/src/CMakeLists.txt" || die
}
src_configure() {
mycmakeargs=(
- $(cmake-utils_use_find_package ruby Ruby)
+ $(cmake_use_find_package ruby Ruby)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
+ if ! use ruby; then
+ rm "${S}/man/linux/${PN}-find.1" || die
+ fi
find "${S}/man/linux" -name '*.1' -exec doman '{}' +
- cmake-utils_src_install
+ cmake_src_install
}