summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-10 00:52:48 +0000
committerSam James <sam@gentoo.org>2021-03-10 00:52:48 +0000
commite7577b1e87d1029c888b5f692abd699677d6aba8 (patch)
treea1838b6e09ec79cb56ec7e78b85452a5779e02d2 /sys-fs/dmraid
parentdev-util/icmake: drop 9.02.09 (diff)
downloadgentoo-e7577b1e87d1029c888b5f692abd699677d6aba8.tar.gz
gentoo-e7577b1e87d1029c888b5f692abd699677d6aba8.tar.bz2
gentoo-e7577b1e87d1029c888b5f692abd699677d6aba8.zip
sys-fs/dmraid: partly modernise latest version
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/dmraid')
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc16-r5.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc16-r5.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc16-r5.ebuild
index 7d42581d1fd8..ac268a35d6c6 100644
--- a/sys-fs/dmraid/dmraid-1.0.0_rc16-r5.ebuild
+++ b/sys-fs/dmraid/dmraid-1.0.0_rc16-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,6 +10,7 @@ MY_PV=${PV/_/.}-3
DESCRIPTION="Device-mapper RAID tool and library"
HOMEPAGE="https://people.redhat.com/~heinzm/sw/dmraid/"
SRC_URI="https://people.redhat.com/~heinzm/sw/dmraid/src/${PN}-${MY_PV}.tar.bz2"
+S="${WORKDIR}/${PN}/${MY_PV}/${PN}"
LICENSE="GPL-2"
SLOT="0"
@@ -17,13 +18,14 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="intel_led led mini static"
RDEPEND=">=sys-fs/lvm2-2.02.45"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
static? ( sys-fs/lvm2[static-libs] )
"
-BDEPEND="virtual/pkgconfig
- app-arch/tar"
-
-S="${WORKDIR}/${PN}/${MY_PV}/${PN}"
+BDEPEND="
+ app-arch/tar
+ virtual/pkgconfig
+"
pkg_setup() {
if kernel_is lt 2 6 ; then
@@ -43,15 +45,18 @@ src_prepare() {
# pkg_check_modules is not in aclocal.m4 by default, and eautoreconf doesnt add it
einfo "Appending pkg.m4 from system to aclocal.m4"
cat "${BROOT}"/usr/share/aclocal/pkg.m4 >>"${S}"/aclocal.m4 || die "Could not append pkg.m4"
- eapply_user
+
+ default
eautoreconf
einfo "Creating prepatched source archive for use with Genkernel"
# archive the patched source for use with genkernel
cd "${WORKDIR}" || die
mkdir -p "tmp/${PN}" || die
+
cp -a "${PN}/${MY_PV}/${PN}" "tmp/${PN}" || die
mv "tmp/${PN}/${PN}" "tmp/${PN}/${MY_PV}" || die
+
cd tmp || die
tar -jcf ${PN}-${MY_PV}-prepatched.tar.bz2 ${PN} || die
mv ${PN}-${MY_PV}-prepatched.tar.bz2 .. || die
@@ -59,7 +64,8 @@ src_prepare() {
src_configure() {
# disable klibc and dietlibc, bug #653392
- econf --with-usrlibdir='${prefix}'/$(get_libdir) \
+ econf \
+ --with-usrlibdir='${prefix}'/$(get_libdir) \
--disable-klibc \
--disable-dietlibc \
$(use_enable static static_link) \
@@ -70,7 +76,9 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install
+
dodoc CHANGELOG README TODO KNOWN_BUGS doc/*
+
insinto /usr/share/${PN}
doins "${WORKDIR}"/${PN}-${MY_PV}-prepatched.tar.bz2
}