summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-03 09:15:33 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-03 09:24:06 +0100
commite32ef6e70e3121038cb3c22acdb4180421c41c05 (patch)
treeae64612cc2ce0ad97318a56ce60776213e7adf4d /sys-fs/duperemove/duperemove-0.11.2.ebuild
parentdev-libs/c-blosc: Remove old (diff)
downloadgentoo-e32ef6e70e3121038cb3c22acdb4180421c41c05.tar.gz
gentoo-e32ef6e70e3121038cb3c22acdb4180421c41c05.tar.bz2
gentoo-e32ef6e70e3121038cb3c22acdb4180421c41c05.zip
sys-fs/duperemove: Bump to 0.11.2
Closes: https://bugs.gentoo.org/707792 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs/duperemove/duperemove-0.11.2.ebuild')
-rw-r--r--sys-fs/duperemove/duperemove-0.11.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/duperemove/duperemove-0.11.2.ebuild b/sys-fs/duperemove/duperemove-0.11.2.ebuild
new file mode 100644
index 000000000000..245dba098bcb
--- /dev/null
+++ b/sys-fs/duperemove/duperemove-0.11.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Btrfs and xfs deduplication utility"
+HOMEPAGE="https://github.com/markfasheh/duperemove"
+SRC_URI="https://github.com/markfasheh/duperemove/archive/v${PV/_/.}.tar.gz -> ${P/_/.}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P/_/.}
+
+src_prepare() {
+ sed -i -e "/VER/s:0.12.dev:${PV}:" Makefile || die
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}