summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-30 11:57:39 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-30 11:57:50 +0100
commit55211db471467eb9e89666db17a299fc3a9ae2bf (patch)
tree55ee85b6c0e772bdceed01610555b4b09da3dfce /sys-fs/e2fsprogs
parentsys-libs/e2fsprogs-libs: Bump to version 1.46.0 (diff)
downloadgentoo-55211db471467eb9e89666db17a299fc3a9ae2bf.tar.gz
gentoo-55211db471467eb9e89666db17a299fc3a9ae2bf.tar.bz2
gentoo-55211db471467eb9e89666db17a299fc3a9ae2bf.zip
sys-fs/e2fsprogs: Bump to version 1.46.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/Manifest1
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.46.0.ebuild144
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.46.0-pthreads_build.patch46
-rw-r--r--sys-fs/e2fsprogs/metadata.xml1
4 files changed, 192 insertions, 0 deletions
diff --git a/sys-fs/e2fsprogs/Manifest b/sys-fs/e2fsprogs/Manifest
index 7802ac565708..3ff83d7d77fc 100644
--- a/sys-fs/e2fsprogs/Manifest
+++ b/sys-fs/e2fsprogs/Manifest
@@ -1,3 +1,4 @@
DIST e2fsprogs-1.42.9-mint-r1.patch.xz 9012 BLAKE2B ae6421587c3cca2f9b26805c5f8d236d3fecde78cc7df3776ae9c23c7f254d7240e06507568fdd2154a16113c47609a8143535ab9cb2925426d3c578d077ce26 SHA512 591a7c80d65082eebcdc455028be6ade05c9aae96c94f654106be0facef330a8875dae82891e6e3ad2b48dece2b4e1c1940dbc47cd3eba3e6eea3b5ddba9a8fc
DIST e2fsprogs-1.45.6.tar.xz 5572144 BLAKE2B 24a44d27a02a1fa178083d5ee6034b20fedcac9faf7cf7f5cfcd4e4cee6d38775bc78949b9b00823cbbdacfab783e8e1e739579b9a7236c5425f51b27600743b SHA512 f3abfb6fe7ef632bb81152e2127d601cadd3fa93162178576a1d5ed82c2286627184b207b85a5b2a1793db0addf0885dfc3b9523bb340443224caf9c6d613b84
DIST e2fsprogs-1.45.7.tar.xz 5570052 BLAKE2B 237ef068c3899641b5eb908cc302c8c6b454e337bce2de95fc96b9a078a003db0c44bd34391063cc2f30a95dcce57950fe900f59ae7d273786c657b7c190b341 SHA512 fcbd66af7b87f2bdec562ddd59c8c5fbd60f32fdd582a5c9d21cb6cfea642d2cdca57b6c29124309798528b2d9ceadf770928a6698f75dc88a47701286128763
+DIST e2fsprogs-1.46.0.tar.xz 7007144 BLAKE2B d902028a0e538a62428e18e3c2a0a917a73351afc7d8eec804ddac459a1b8c2e11d104201235fb64170acc78942d2c9d5a45039f770cf5ce537cdba18cd559e6 SHA512 c865360e532da42264200934229aa9cfc88c3342fc4e206e82d1fe2a908b0fd3b58f2e9a4796f2ecdeafe1ace9f9ee444ea5b2e3efd488cb934f9a22af6a8f7e
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.46.0.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.46.0.ebuild
new file mode 100644
index 000000000000..3bab0326f347
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.46.0.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic systemd toolchain-funcs udev usr-ldscript
+
+DESCRIPTION="Standard EXT2/EXT3/EXT4 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="https://www.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/v${PV}/${P}.tar.xz
+ elibc_mintlib? ( mirror://gentoo/${PN}-1.42.9-mint-r1.patch.xz )"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="cron fuse lto nls static-libs +threads elibc_FreeBSD"
+
+RDEPEND="~sys-libs/${PN}-libs-${PV}
+ >=sys-apps/util-linux-2.16
+ cron? ( sys-fs/lvm2[-device-mapper-only(-)] )
+ fuse? ( sys-fs/fuse:0 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+ sys-apps/texinfo
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.40-fbsd.patch
+ "${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch #516854
+
+ # Upstream patches (can usually removed with next version bump)
+ "${FILESDIR}/${P}-pthreads_build.patch"
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *-mint* ]] ; then
+ PATCHES+=( "${WORKDIR}"/${PN}-1.42.9-mint-r1.patch )
+ fi
+
+ default
+
+ cp doc/RelNotes/v${PV}.txt ChangeLog || die "Failed to copy Release Notes"
+
+ # Get rid of doc -- we don't use them. This also prevents a sandbox
+ # violation due to mktexfmt invocation
+ rm -r doc || die "Failed to remove doc dir"
+
+ # blargh ... trick e2fsprogs into using e2fsprogs-libs
+ sed -i -r \
+ -e 's:@LIBINTL@:@LTLIBINTL@:' \
+ -e '/^(STATIC_)?LIB(COM_ERR|SS)/s:[$][(]LIB[)]/lib([^@]*)@(STATIC_)?LIB_EXT@:-l\1:' \
+ -e '/^DEP(STATIC_)?LIB(COM_ERR|SS)/s:=.*:=:' \
+ MCONFIG.in || die "muck libs" #122368
+ sed -i -r \
+ -e '/^LIB_SUBDIRS/s:lib/(et|ss)::g' \
+ Makefile.in || die "remove subdirs"
+ ln -s $(which mk_cmds) lib/ss/ || die
+
+ # Avoid rebuild
+ echo '#include_next <ss/ss_err.h>' > lib/ss/ss_err.h
+}
+
+src_configure() {
+ # Keep the package from doing silly things #261411
+ export VARTEXFONTS="${T}/fonts"
+
+ # needs open64() prototypes and friends
+ append-cppflags -D_GNU_SOURCE
+
+ local myeconfargs=(
+ --with-root-prefix="${EPREFIX}"
+ $(use_with cron crond-dir "${EPREFIX}/etc/cron.d")
+ --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ --with-udev-rules-dir="${EPREFIX}$(get_udevdir)/rules.d"
+ --enable-symlink-install
+ --enable-elf-shlibs
+ $(tc-has-tls || echo --disable-tls)
+ $(use_enable fuse fuse2fs)
+ $(use_enable nls)
+ --disable-libblkid
+ --disable-libuuid
+ --disable-fsck
+ --disable-uuidd
+ $(use_enable lto)
+ $(use_enable threads pthread)
+ )
+ ac_cv_path_LDCONFIG=: econf "${myeconfargs[@]}"
+
+ if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
+ eerror "INTL sanity check failed, aborting build."
+ eerror "Please post your ${S}/config.log file as an"
+ eerror "attachment to https://bugs.gentoo.org/show_bug.cgi?id=81096"
+ die "Preventing included intl cruft from building"
+ fi
+}
+
+src_compile() {
+ emake V=1 COMPILE_ET=compile_et MK_CMDS=mk_cmds
+
+ # Build the FreeBSD helper
+ if use elibc_FreeBSD ; then
+ cp "${FILESDIR}"/fsck_ext2fs.c .
+ emake V=1 fsck_ext2fs
+ fi
+}
+
+src_install() {
+ # need to set root_libdir= manually as any --libdir options in the
+ # econf above (i.e. multilib) will screw up the default #276465
+ emake \
+ STRIP=: \
+ root_libdir="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" \
+ install
+
+ einstalldocs
+
+ insinto /etc
+ doins "${FILESDIR}"/e2fsck.conf
+
+ # Move shared libraries to /lib/, install static libraries to
+ # /usr/lib/, and install linker scripts to /usr/lib/.
+ gen_usr_ldscript -a e2p ext2fs
+
+ # configure doesn't have an option to disable static libs :/
+ if ! use static-libs ; then
+ find "${ED}" -name '*.a' -delete || die
+ fi
+
+ if use elibc_FreeBSD ; then
+ # Install helpers for us
+ into /
+ dosbin "${S}"/fsck_ext2fs
+ doman "${FILESDIR}"/fsck_ext2fs.8
+
+ # filefrag is linux only
+ rm \
+ "${ED}"/usr/sbin/filefrag \
+ "${ED}"/usr/share/man/man8/filefrag.8 || die
+ fi
+}
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.46.0-pthreads_build.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.46.0-pthreads_build.patch
new file mode 100644
index 000000000000..9d251d2f0b37
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/e2fsprogs-1.46.0-pthreads_build.patch
@@ -0,0 +1,46 @@
+From 24487a7fa64bfa92bea21be3ca8c155e5de7438f Mon Sep 17 00:00:00 2001
+From: Theodore Ts'o <tytso@mit.edu>
+Date: Fri, 29 Jan 2021 22:28:31 -0500
+Subject: configure.ac: fix build failure on systems with pthreads && !fuse
+ support
+
+The configure script checks for pthread.h as part of double-checking
+that the FUSE support works correctly, which implicitly defined
+HAVE_PHREAD_H. If the FUSE libraries are not present (or fuse support
+is explicitly disabled), this check doesn't happen and so
+HAVE_PTHREAD_H is not defined, and this causes a build failure.
+
+Signed-off-by: Theodore Ts'o <tytso@mit.edu>
+---
+ configure | 2 +-
+ configure.ac | 1 +
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure b/configure
+index 9d41d069..6b8b7f4b 100755
+--- a/configure
++++ b/configure
+@@ -10448,7 +10448,7 @@ fi
+ done
+
+ fi
+-for ac_header in dirent.h errno.h execinfo.h getopt.h malloc.h mntent.h paths.h semaphore.h setjmp.h signal.h stdarg.h stdint.h stdlib.h termios.h termio.h unistd.h utime.h attr/xattr.h linux/falloc.h linux/fd.h linux/fsmap.h linux/major.h linux/loop.h linux/types.h net/if_dl.h netinet/in.h sys/acl.h sys/disklabel.h sys/disk.h sys/file.h sys/ioctl.h sys/key.h sys/mkdev.h sys/mman.h sys/mount.h sys/prctl.h sys/resource.h sys/select.h sys/socket.h sys/sockio.h sys/stat.h sys/syscall.h sys/sysmacros.h sys/time.h sys/types.h sys/un.h sys/wait.h sys/xattr.h
++for ac_header in dirent.h errno.h execinfo.h getopt.h malloc.h mntent.h paths.h pthread.h semaphore.h setjmp.h signal.h stdarg.h stdint.h stdlib.h termios.h termio.h unistd.h utime.h attr/xattr.h linux/falloc.h linux/fd.h linux/fsmap.h linux/major.h linux/loop.h linux/types.h net/if_dl.h netinet/in.h sys/acl.h sys/disklabel.h sys/disk.h sys/file.h sys/ioctl.h sys/key.h sys/mkdev.h sys/mman.h sys/mount.h sys/prctl.h sys/resource.h sys/select.h sys/socket.h sys/sockio.h sys/stat.h sys/syscall.h sys/sysmacros.h sys/time.h sys/types.h sys/un.h sys/wait.h sys/xattr.h
+ do :
+ as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
+diff --git a/configure.ac b/configure.ac
+index 141c4d9c..42b6f486 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -975,6 +975,7 @@ AC_CHECK_HEADERS(m4_flatten([
+ malloc.h
+ mntent.h
+ paths.h
++ pthread.h
+ semaphore.h
+ setjmp.h
+ signal.h
+--
+cgit 1.2.3-1.el7
+
diff --git a/sys-fs/e2fsprogs/metadata.xml b/sys-fs/e2fsprogs/metadata.xml
index fd229917a073..05a9b85ad268 100644
--- a/sys-fs/e2fsprogs/metadata.xml
+++ b/sys-fs/e2fsprogs/metadata.xml
@@ -8,6 +8,7 @@
<use>
<flag name="cron">Install e2scrub_all cron script</flag>
<flag name='fuse'>Build fuse2fs, a FUSE file system client for ext2/ext3/ext4 file systems</flag>
+ <flag name="lto">Build with link time optimization (LTO)</flag>
</use>
<upstream>
<remote-id type="cpe">cpe:/a:e2fsprogs_project:e2fsprogs</remote-id>