summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/exfat-utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/exfat-utils')
-rw-r--r--sys-fs/exfat-utils/Manifest3
-rw-r--r--sys-fs/exfat-utils/exfat-utils-1.0.1.ebuild29
-rw-r--r--sys-fs/exfat-utils/exfat-utils-1.1.0.ebuild29
-rw-r--r--sys-fs/exfat-utils/exfat-utils-1.1.1.ebuild29
-rw-r--r--sys-fs/exfat-utils/metadata.xml12
5 files changed, 102 insertions, 0 deletions
diff --git a/sys-fs/exfat-utils/Manifest b/sys-fs/exfat-utils/Manifest
new file mode 100644
index 000000000000..886868cf222f
--- /dev/null
+++ b/sys-fs/exfat-utils/Manifest
@@ -0,0 +1,3 @@
+DIST exfat-utils-1.0.1.tar.gz 51905 SHA256 eeacedca1878065dc3886674ae39cd51149c37bd7d6d7e9325c971a1d1acdab3 SHA512 e2716e902110858e33e21395c45881315cbe469cf5192de130031ce989bdcb388944ad22d8588ae1a29d682615809be886086d313d5ab46b3aafa6d356a0e8ac WHIRLPOOL 7d78afd9a37fed433704d8b6873d8ab19bd3d4e5c0e5951961f743768483c9843d51aa7342ec67e36466bb3141085a44c2d6ac6140f23361a4efd0d4ebcc6de1
+DIST exfat-utils-1.1.0.tar.gz 48723 SHA256 68a7943db27548b6aecb6305b3b5064e242945502f03ba95a5d14938a18cc94e SHA512 a672c4a1a90b652c991631db92ac2f59b4fe504d31c61b31e64f96d36bb0154c307c05134972f357bfb0f4006015381c65fee961edcfcfe6bf3c7d7dadf7f2eb WHIRLPOOL ff8f0964ff837118fe07632ed92e94d995d55650d9cf6fe391c1d67d65ba8fecb4d4a70740807d6f7591be0dcc49ccf3d760d32d042e937fc42e9558b1b21d02
+DIST exfat-utils-1.1.1.tar.gz 48754 SHA256 c64454083961fbad164fa7daef03d7e9247aa978c11395d62a265d48a1d56232 SHA512 d2ebf216a826734937402ff62c020d16c425e092cee5065a48bc7dca9d1e47e5906fc7bf3665ae553d819b0e2e066b1a882ad0bd2a6ab6caed50565f431ee253 WHIRLPOOL be4beda5a8dfa173553f9d03f019814195aa07506a0d6e31c7682b2f994e88e6673566f46dab77ad28784fd9551e0fe8d8f5e24922388f2fbdd181010c05fa7a
diff --git a/sys-fs/exfat-utils/exfat-utils-1.0.1.ebuild b/sys-fs/exfat-utils/exfat-utils-1.0.1.ebuild
new file mode 100644
index 000000000000..9f67f8425203
--- /dev/null
+++ b/sys-fs/exfat-utils/exfat-utils-1.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit scons-utils toolchain-funcs
+
+DESCRIPTION="exFAT filesystem utilities"
+HOMEPAGE="http://code.google.com/p/exfat/"
+SRC_URI="http://exfat.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc64 ~s390 ~sh ~sparc x86 ~arm-linux ~x86-linux"
+IUSE=""
+
+src_compile() {
+ tc-export AR CC RANLIB
+ escons CCFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin dump/dumpexfat label/exfatlabel mkfs/mkexfatfs fsck/exfatfsck
+ dosym mkexfatfs /usr/bin/mkfs.exfat
+ dosym exfatfsck /usr/bin/fsck.exfat
+
+ doman */*.8
+ dodoc ChangeLog
+}
diff --git a/sys-fs/exfat-utils/exfat-utils-1.1.0.ebuild b/sys-fs/exfat-utils/exfat-utils-1.1.0.ebuild
new file mode 100644
index 000000000000..4782ed1f3a20
--- /dev/null
+++ b/sys-fs/exfat-utils/exfat-utils-1.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit scons-utils toolchain-funcs
+
+DESCRIPTION="exFAT filesystem utilities"
+HOMEPAGE="http://code.google.com/p/exfat/"
+SRC_URI="http://docs.google.com/uc?export=download&id=0B7CLI-REKbE3bnR2WHowZXNtUVU -> ${P}.tar.gz"
+
+LICENSE="GPL-2+" # COPYING is GPL-2 but ChangeLog says "Relicensed the project from GPLv3+ to GPLv2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE=""
+
+src_compile() {
+ tc-export AR CC RANLIB
+ escons CCFLAGS="${CFLAGS} -Wall -std=c99"
+}
+
+src_install() {
+ dobin dump/dumpexfat label/exfatlabel mkfs/mkexfatfs fsck/exfatfsck
+ dosym mkexfatfs /usr/bin/mkfs.exfat
+ dosym exfatfsck /usr/bin/fsck.exfat
+
+ doman */*.8
+ dodoc ChangeLog
+}
diff --git a/sys-fs/exfat-utils/exfat-utils-1.1.1.ebuild b/sys-fs/exfat-utils/exfat-utils-1.1.1.ebuild
new file mode 100644
index 000000000000..cf2b9f43c1c0
--- /dev/null
+++ b/sys-fs/exfat-utils/exfat-utils-1.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit scons-utils toolchain-funcs
+
+DESCRIPTION="exFAT filesystem utilities"
+HOMEPAGE="http://code.google.com/p/exfat/"
+SRC_URI="https://docs.google.com/uc?export=download&id=0B7CLI-REKbE3UzNtSkRvdHBpdjQ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+" # COPYING is GPL-2 but ChangeLog says "Relicensed the project from GPLv3+ to GPLv2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE=""
+
+src_compile() {
+ tc-export AR CC RANLIB
+ escons CCFLAGS="${CFLAGS} -Wall -std=c99"
+}
+
+src_install() {
+ dobin dump/dumpexfat label/exfatlabel mkfs/mkexfatfs fsck/exfatfsck
+ dosym mkexfatfs /usr/bin/mkfs.exfat
+ dosym exfatfsck /usr/bin/fsck.exfat
+
+ doman */*.8
+ dodoc ChangeLog
+}
diff --git a/sys-fs/exfat-utils/metadata.xml b/sys-fs/exfat-utils/metadata.xml
new file mode 100644
index 000000000000..7b05b18e4457
--- /dev/null
+++ b/sys-fs/exfat-utils/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">exfat</remote-id>
+ </upstream>
+</pkgmetadata>