summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-01-16 12:35:49 -0500
committerTim Harder <radhermit@gentoo.org>2016-01-16 13:00:52 -0500
commitb7707160a0876a3349ce52e76124fcffa027b044 (patch)
tree9920620f1935d895bbb74d3553b3ad3feacc28e7 /sys-fs/fuse
parentsys-fs/fuse: stabilize 2.9.4 for arm64 (diff)
downloadgentoo-b7707160a0876a3349ce52e76124fcffa027b044.tar.gz
gentoo-b7707160a0876a3349ce52e76124fcffa027b044.tar.bz2
gentoo-b7707160a0876a3349ce52e76124fcffa027b044.zip
sys-fs/fuse: remove old, insecure version (bug #550152)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/Manifest1
-rw-r--r--sys-fs/fuse/fuse-2.9.3.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/sys-fs/fuse/Manifest b/sys-fs/fuse/Manifest
index c4459b97fdc9..0cd19d3dcbda 100644
--- a/sys-fs/fuse/Manifest
+++ b/sys-fs/fuse/Manifest
@@ -1,2 +1 @@
-DIST fuse-2.9.3.tar.gz 572044 SHA256 0beb83eaf2c5e50730fc553406ef124d77bc02c64854631bdfc86bfd6437391c SHA512 03f43f88694ec7e039ff3579a8e76349b5a5a05872c55901fc1d9ee53dbb6b1e69f6dd0005b620f3b5ead0b14da8eeb31d46b922d10f88f4e3f830aa47e8162c WHIRLPOOL 739562e48e85326049dac0ef06653e5e6574a01dd60649e23ddc0990ea6c1979e6ce952a1e84d0776b706fbcad79eb0e1328aa35f70ba4881db9a4482d254a04
DIST fuse-2.9.4.tar.gz 577282 SHA256 6be9c0bff6af8c677414935f31699ea5a7f8f5f791cfa5205be02ea186b97ce1 SHA512 055ec2a78793276102bc5a0afea9eebd18b151cf752d0985380ffbde1c554e9fb7bc3a43838618e3957b274aa06624303ea12f32c659365c4768dad887bb557d WHIRLPOOL 6c866ba05be5a56e1b1d8793378c0c5c683375e9baad6de22344adaf5bb35021182b15783f59911259f98cb914ef4a1cb70be0cb9b5cd6625173b3b6454c32d7
diff --git a/sys-fs/fuse/fuse-2.9.3.ebuild b/sys-fs/fuse/fuse-2.9.3.ebuild
deleted file mode 100644
index 79a7b7daecb4..000000000000
--- a/sys-fs/fuse/fuse-2.9.3.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit eutils libtool linux-info udev toolchain-funcs
-
-MY_P=${P/_/-}
-DESCRIPTION="An interface for filesystems implemented in userspace"
-HOMEPAGE="http://fuse.sourceforge.net"
-SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="examples kernel_linux kernel_FreeBSD static-libs"
-
-PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-DEPEND="virtual/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- if use kernel_linux ; then
- if kernel_is lt 2 6 9 ; then
- die "Your kernel is too old."
- fi
- CONFIG_CHECK="~FUSE_FS"
- FUSE_FS_WARNING="You need to have FUSE module built to use user-mode utils"
- linux-info_pkg_setup
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-kernel-types.patch
- # sandbox violation with mtab writability wrt #438250
- # don't sed configure.in without eautoreconf because of maintainer mode
- sed -i 's:umount --fake:true --fake:' configure || die
- elibtoolize
-}
-
-src_configure() {
- econf \
- INIT_D_PATH="${EPREFIX}/etc/init.d" \
- MOUNT_FUSE_PATH="${EPREFIX}/sbin" \
- UDEV_RULES_PATH="${EPREFIX}/$(get_udevdir)/rules.d" \
- $(use_enable static-libs static) \
- --disable-example
-}
-
-src_install() {
- default
-
- dodoc AUTHORS ChangeLog Filesystems README \
- README.NFS NEWS doc/how-fuse-works \
- doc/kernel.txt FAQ
-
- if use examples ; then
- docinto examples
- dodoc example/*
- fi
-
- if use kernel_linux ; then
- newinitd "${FILESDIR}"/fuse.init fuse
- elif use kernel_FreeBSD ; then
- insinto /usr/include/fuse
- doins include/fuse_kernel.h
- newinitd "${FILESDIR}"/fuse-fbsd.init fuse
- else
- die "We don't know what init code install for your kernel, please file a bug."
- fi
-
- prune_libtool_files
- rm -rf "${D}"/dev
-
- dodir /etc
- cat > "${ED}"/etc/fuse.conf <<-EOF
- # Set the maximum number of FUSE mounts allowed to non-root users.
- # The default is 1000.
- #
- #mount_max = 1000
-
- # Allow non-root users to specify the 'allow_other' or 'allow_root'
- # mount options.
- #
- #user_allow_other
- EOF
-}