summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-22 11:10:34 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-22 14:02:22 +0200
commitc7fac4a987fe4cdadb9e93412e2a6083913ba4a8 (patch)
treeecf3fa26999150398f4c7e014989aec4a3521965 /sys-fs/inotify-tools
parentpackage.mask: midori bugs solved (diff)
downloadgentoo-c7fac4a987fe4cdadb9e93412e2a6083913ba4a8.tar.gz
gentoo-c7fac4a987fe4cdadb9e93412e2a6083913ba4a8.tar.bz2
gentoo-c7fac4a987fe4cdadb9e93412e2a6083913ba4a8.zip
sys-fs/inotify-tools: Handle --docdir correctly on Prefix (bug #591676).
Bumped EAPI to 6. Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/inotify-tools')
-rw-r--r--sys-fs/inotify-tools/inotify-tools-3.14.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-fs/inotify-tools/inotify-tools-3.14.ebuild b/sys-fs/inotify-tools/inotify-tools-3.14.ebuild
index b46ff1959652..843920918aa1 100644
--- a/sys-fs/inotify-tools/inotify-tools-3.14.ebuild
+++ b/sys-fs/inotify-tools/inotify-tools-3.14.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
DESCRIPTION="a set of command-line programs providing a simple interface to inotify"
HOMEPAGE="https://github.com/rvoicilas/inotify-tools/wiki"
-SRC_URI="https://github.com/downloads/rvoicilas/${PN}/${P}.tar.gz"
+SRC_URI="mirror://github/rvoicilas/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -17,6 +17,7 @@ DEPEND="doc? ( app-doc/doxygen )"
RDEPEND=""
src_prepare() {
+ default
# timestamps are busted in tarball
find . -type f -exec touch -r configure {} +
}
@@ -24,7 +25,7 @@ src_prepare() {
src_configure() {
# only docs installed are doxygen ones, so use /html
econf \
- --docdir=/usr/share/doc/${PF}/html \
+ --docdir='$(datarootdir)'/doc/${PF}/html \
$(use_enable doc doxygen)
}