summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-20 19:33:52 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-20 19:50:17 +0200
commit421df5f64771c31ae2e664029023ef41a133a875 (patch)
tree00b3bd517f633e437aa3a94ec911fbfe6ff79888 /sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild
parentsys-fs/jfsutils: migrate to EAPI=7 (diff)
downloadgentoo-421df5f64771c31ae2e664029023ef41a133a875.tar.gz
gentoo-421df5f64771c31ae2e664029023ef41a133a875.tar.bz2
gentoo-421df5f64771c31ae2e664029023ef41a133a875.zip
sys-fs/jfsutils: don't call AR directly
Closes: https://bugs.gentoo.org/726032 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild')
-rw-r--r--sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild b/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild
index b618e667ca77..d1f28184fb48 100644
--- a/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild
+++ b/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic
+inherit autotools flag-o-matic
DESCRIPTION="IBM's Journaling Filesystem (JFS) Utilities"
HOMEPAGE="http://jfs.sourceforge.net/"
@@ -19,8 +19,15 @@ DOCS=( AUTHORS ChangeLog NEWS README )
PATCHES=(
"${FILESDIR}"/${P}-linux-headers.patch #448844
"${FILESDIR}"/${P}-sysmacros.patch #580056
+ "${FILESDIR}"/${P}-check-for-ar.patch #726032
)
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
src_configure() {
# It doesn't compile on alpha without this LDFLAGS
use alpha && append-ldflags "-Wl,--no-relax"