summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2017-03-19 21:02:40 -0500
committerErik Mackdanz <stasibear@gentoo.org>2017-03-19 21:02:40 -0500
commite3e0e087b3efc6d1ba2c93b8bbaa65c03b1ad2eb (patch)
treedb97cffb19d1620bd381ace74f993cddf2b1879f /sys-fs/lxcfs
parentsys-devel/binutils: alpha stable, bug 595288 (diff)
downloadgentoo-e3e0e087b3efc6d1ba2c93b8bbaa65c03b1ad2eb.tar.gz
gentoo-e3e0e087b3efc6d1ba2c93b8bbaa65c03b1ad2eb.tar.bz2
gentoo-e3e0e087b3efc6d1ba2c93b8bbaa65c03b1ad2eb.zip
sys-fs/lxcfs: version bump to 2.0.6
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sys-fs/lxcfs')
-rw-r--r--sys-fs/lxcfs/Manifest1
-rw-r--r--sys-fs/lxcfs/files/lxcfs-2.0.6-fusermount-path.patch11
-rw-r--r--sys-fs/lxcfs/files/lxcfs-2.0.6.initd26
-rw-r--r--sys-fs/lxcfs/lxcfs-2.0.6.ebuild70
4 files changed, 108 insertions, 0 deletions
diff --git a/sys-fs/lxcfs/Manifest b/sys-fs/lxcfs/Manifest
index 2871694fdde6..f159e85e3f68 100644
--- a/sys-fs/lxcfs/Manifest
+++ b/sys-fs/lxcfs/Manifest
@@ -1,2 +1,3 @@
DIST lxcfs-2.0.3.tar.gz 51078 SHA256 742a6cc463dc66179c334ebca4c3276888ef27a564e5e47212b60c655a811a72 SHA512 14caa2d6598529610ef6bd4c1d6f4d4598e8dc1378a3ee35ea7a1582c11150c896facc80216e67526384995891d9cc1244796860b790ecfc8bf735cc2cd80923 WHIRLPOOL f2de2438e4e521db5135ca81daceccdc1d3820907de9d37842c9bafa112cc416774cb2efe27b815cecccc26e55617c7eb9f5d076df5423ab354747605fa90643
DIST lxcfs-2.0.4.tar.gz 52639 SHA256 9af8199dba2837542ede6e50489100220472241e4b355b685e66c9a72bbcf81a SHA512 1c701fbd60799a1f7ad7e809c2e52ef0d26ed44e96c2c0376d3c4eb203aafb99ddcaff015f3fa8cc9c1219449210f6bf93844cc568de3a9f55cb8801328cec90 WHIRLPOOL 1ac966bab786b00a236225e1856c46fa9d419e42853edcd1181fc3f43d54becb60435fa0679a6a0f838a5edeb920205e3baa734118a4b5d9587e547fd63e3704
+DIST lxcfs-2.0.6.tar.gz 62632 SHA256 be4ea891887aee2c04b2d9ff5dbb6866178cc1276119f5b116bf3f99c7750213 SHA512 52baf15eb9dc2b694085635f7d8e5c6f1207099173cda607d758b8837a720e4808cacbf83f900a6734d3260d34abafbebdcbb0618cb3cf67c5d304f50d66244d WHIRLPOOL 0d7fc69400678f03dd8ccb06fee643feaa62469e6287a6bc3935232f775bc93fa5c1d649e7747b3b09867f2678593eaf923c947499c549cfd6c40fcd28620a95
diff --git a/sys-fs/lxcfs/files/lxcfs-2.0.6-fusermount-path.patch b/sys-fs/lxcfs/files/lxcfs-2.0.6-fusermount-path.patch
new file mode 100644
index 000000000000..61d3494fb7f3
--- /dev/null
+++ b/sys-fs/lxcfs/files/lxcfs-2.0.6-fusermount-path.patch
@@ -0,0 +1,11 @@
+--- /config/init/systemd/lxcfs.service.orig 2016-07-11 01:18:57.688074437 +0000
++++ /config/init/systemd/lxcfs.service 2016-07-11 01:19:48.516477185 +0000
+@@ -7,7 +7,7 @@
+ ExecStart=/usr/bin/lxcfs /var/lib/lxcfs/
+ KillMode=process
+ Restart=on-failure
+-ExecStopPost=-/bin/fusermount -u /var/lib/lxcfs
++ExecStopPost=-/usr/bin/fusermount -u /var/lib/lxcfs
+ Delegate=yes
+
+ [Install]
diff --git a/sys-fs/lxcfs/files/lxcfs-2.0.6.initd b/sys-fs/lxcfs/files/lxcfs-2.0.6.initd
new file mode 100644
index 000000000000..dfc5725f693f
--- /dev/null
+++ b/sys-fs/lxcfs/files/lxcfs-2.0.6.initd
@@ -0,0 +1,26 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DAEMON=/usr/bin/lxcfs
+PIDFILE=/run/lxcfs.pid
+
+start() {
+ ebegin "Starting lxcfs"
+
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${DAEMON} \
+ --background \
+ --make-pidfile \
+ -- \
+ -f -o allow_other /var/lib/lxcfs
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping lxcfs"
+ start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
+ eend $?
+}
diff --git a/sys-fs/lxcfs/lxcfs-2.0.6.ebuild b/sys-fs/lxcfs/lxcfs-2.0.6.ebuild
new file mode 100644
index 000000000000..bc296b6a704e
--- /dev/null
+++ b/sys-fs/lxcfs/lxcfs-2.0.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd vcs-snapshot versionator
+DESCRIPTION="FUSE filesystem for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/lxc/lxcfs.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ # e.g. upstream is 2.0.0.beta2, we want 2.0.0_beta2
+ UPSTREAM_PV=$(replace_version_separator 3 '.' )
+ SRC_URI="https://github.com/lxc/lxcfs/archive/${PN}-${UPSTREAM_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+IUSE="pam"
+
+# Omit all dbus. Upstream appears to require it because systemd, but
+# lxcfs makes no direct use of dbus.
+RDEPEND="
+ dev-libs/glib:2
+ sys-fs/fuse
+ virtual/pam
+"
+DEPEND="
+ sys-apps/help2man
+ ${RDEPEND}
+"
+PATCHES="${FILESDIR}/${P}-fusermount-path.patch"
+
+src_prepare() {
+ default
+ ./bootstrap.sh || die "Failed to bootstrap configure files"
+}
+
+src_configure() {
+ use pam || pamflag="--with-pamdir=none"
+
+ # Without the localstatedir the filesystem isn't mounted correctly
+ econf --localstatedir=/var ${pamflag}
+}
+
+# Test suite fails for me
+# src_test() {
+# emake tests
+# tests/main.sh || die "Tests failed"
+# }
+
+src_install() {
+ default
+ dodir /var/lib/lxcfs
+ newinitd "${FILESDIR}"/${P}.initd lxcfs
+ systemd_dounit config/init/systemd/lxcfs.service
+}
+
+pkg_preinst() {
+ # In an upgrade situation merging /var/lib/lxcfs (an empty dir)
+ # fails because that is a live mountpoint when the service is
+ # running. It's unnecessary anyway so skip the action.
+ [[ -d ${ROOT}/var/lib/lxcfs ]] && rm -rf ${D}/var
+}