summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-07-19 14:03:33 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-07-19 14:15:35 +0300
commitee803b4603cc39345318e3c95af973edf60eb6e0 (patch)
tree157c0a74203f5d6049d543e414413fcc183a8a81 /sys-fs/lxcfs
parentapp-emulation/aqemu: add patch for missing include (diff)
downloadgentoo-ee803b4603cc39345318e3c95af973edf60eb6e0.tar.gz
gentoo-ee803b4603cc39345318e3c95af973edf60eb6e0.tar.bz2
gentoo-ee803b4603cc39345318e3c95af973edf60eb6e0.zip
sys-fs/lxcfs: bump to 4.0.9
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs/lxcfs')
-rw-r--r--sys-fs/lxcfs/Manifest2
-rw-r--r--sys-fs/lxcfs/lxcfs-4.0.9.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-fs/lxcfs/Manifest b/sys-fs/lxcfs/Manifest
index 641404b741ac..cd5ab0a451f8 100644
--- a/sys-fs/lxcfs/Manifest
+++ b/sys-fs/lxcfs/Manifest
@@ -1,2 +1,4 @@
DIST lxcfs-4.0.8.tar.gz 458975 BLAKE2B 19ac81c36c3aad0ee3301eda73aa29399304dff1c827041678be73c4134181667a4d92b3efa37a44b2853b825031fef2e07e7cbfcaf552676a01f5f9faedf9c3 SHA512 830a4a25583a645b59c75327701af24c239323bfe822180c2cb7cb7cc284f50e8bb7c38e771ea869b4449370af1ab1a4fed9611c6495883d193f5a0f6f71380e
DIST lxcfs-4.0.8.tar.gz.asc 833 BLAKE2B da4ef0f8d6dea59d83f708b6aa7c1835773537e3111d8e9aaf4a7c111d21a0b57486cc9828919bea55ea06ee6bf3e03eeae89eb26199e287066b309d6d798c8d SHA512 f8fc10e52472fff599df7e008d34346489754d64347d005794a4b280949130bb0370ade0d65c9eb182914cae3a6c55f9872bc38481b0b64ea1218c8d1640a74f
+DIST lxcfs-4.0.9.tar.gz 453383 BLAKE2B 06694218d45d93baa9041aeae39e52d827ca1b53d616284d0ee04ddfe98436a15b3cf900c7b58f14e506a0726f30679b0a04e6b5047087201ad2a9c35f0cc09e SHA512 c8d02cefb42dee82ea9467631e8e59243a6cb06d4ea53f0ce8da0a9bbc9018480bb0f12723091da672446a75ba200cca044b84c2f13388009dde9e5ad0ca3ebe
+DIST lxcfs-4.0.9.tar.gz.asc 833 BLAKE2B fa71f7a6a7a35fbc7613ec2d7549197fe0d33c9584aea86fe3db959848eeb1b0e69a75ca2d596578f3c7f3a9deca5cec1badce428b4aa52e6f112cf3fe544b3b SHA512 fd9feac31469db7785c8b486ddc4f5c0431ab2aa52aed715e853fcab322e8c6ee755aa87d9bdee7a969a8030be1956863662f8b2db09bfe4b8ba69ef8f2fbb3e
diff --git a/sys-fs/lxcfs/lxcfs-4.0.9.ebuild b/sys-fs/lxcfs/lxcfs-4.0.9.ebuild
new file mode 100644
index 000000000000..61b57c9974a8
--- /dev/null
+++ b/sys-fs/lxcfs/lxcfs-4.0.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd verify-sig
+
+DESCRIPTION="FUSE filesystem for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/ https://github.com/lxc/lxcfs/"
+SRC_URI="https://linuxcontainers.org/downloads/lxcfs/${P}.tar.gz
+ verify-sig? ( https://linuxcontainers.org/downloads/lxcfs/${P}.tar.gz.asc )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/glib:2
+ sys-fs/fuse:3"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/help2man
+ verify-sig? ( app-crypt/openpgp-keys-linuxcontainers )"
+
+# Test files need to be updated to fuse:3, #764620
+RESTRICT="test"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Without the localstatedir the filesystem isn't mounted correctly
+ # Without with-distro ./configure will fail when cross-compiling
+ econf --localstatedir=/var --with-distro=gentoo --disable-static
+}
+
+src_test() {
+ cd tests/ || die
+ emake tests
+ ./main.sh || die "Tests failed"
+}
+
+src_install() {
+ default
+
+ newconfd "${FILESDIR}"/lxcfs-4.0.0.confd lxcfs
+ newinitd "${FILESDIR}"/lxcfs-4.0.0.initd lxcfs
+
+ # Provide our own service file (copy of upstream) due to paths being different from upstream,
+ # #728470
+ systemd_newunit "${FILESDIR}"/lxcfs-4.0.0.service lxcfs.service
+
+ find "${ED}" -name '*.la' -delete || die
+}