summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-10-10 21:40:22 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-10-10 21:47:44 +0200
commit6a1123b2ad8fa7c112797aa49212059e6cb12a2f (patch)
treec082a55d3484d0844c262f4dd64d877e3566feaa /sys-fs/multipath-tools
parentsys-apps/openrc: 0.32.1 version bump (diff)
downloadgentoo-6a1123b2ad8fa7c112797aa49212059e6cb12a2f.tar.gz
gentoo-6a1123b2ad8fa7c112797aa49212059e6cb12a2f.tar.bz2
gentoo-6a1123b2ad8fa7c112797aa49212059e6cb12a2f.zip
sys-fs/multipath-tools: Bump to v0.7.3
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'sys-fs/multipath-tools')
-rw-r--r--sys-fs/multipath-tools/Manifest1
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.7.3-fix-build-without-systemd.patch39
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.7.3.ebuild96
3 files changed, 136 insertions, 0 deletions
diff --git a/sys-fs/multipath-tools/Manifest b/sys-fs/multipath-tools/Manifest
index f62c491023d0..e732cfda8c44 100644
--- a/sys-fs/multipath-tools/Manifest
+++ b/sys-fs/multipath-tools/Manifest
@@ -2,3 +2,4 @@ DIST multipath-tools-0.5.0.tar.bz2 184024 SHA256 f13cf1eb84e94e83b2019e68f796552
DIST multipath-tools-0.6.4.tar.gz 285448 SHA256 1e2747883320f7db854201e5bfb97216e7518468f03503985382ce2c69e5558b SHA512 ec35c6c26c3b233ebece7136ea99dd4c0dff2927e7b543e7091219dc7065fe87e609a1eda9ab6d08399d44fe882d70c8dbe6be9ab175d154c5dd2d12ee1d86ea WHIRLPOOL 6138ba1cbb814bbf53e7a5113f50325d7a7d7088ff2b0f83f1e574f0644241e368cc6b5223eca039b414a0a459a52413d396ea214ff3eaa57f0681e8322b2d9d
DIST multipath-tools-0.7.1.tar.gz 329008 SHA256 d788aaf3ea862b44b5aa07eaa0e5696061f972a1a46d0f469c4a4f4c477c1970 SHA512 81ceb3887250a691b94cb49b7141ace4fc1f69d7f8381e517560dfc7c51ee4c5a1f4f4e40a0b368cf5f7381697fa746b856cbade8990c1608cbcd77248946a82 WHIRLPOOL 2bcc7cc2f425ca3f3f634807cafb7817b54b83d82987a09c9dd530dca1375175a7d52f1854bdd6d5f37c3b1fcf7bc34d67fc2dcae5809dfae968b313c8c86cba
DIST multipath-tools-0.7.2.tar.gz 335187 SHA256 e4273527b8a8e31d596221dd74fdeb9f2b7558d59e514bc7eb040d077bddf24b SHA512 9637e6c69ecfe8dbfb55794569017051961dbe39fa1019000e4be9c2c888a5b6d13ae360af8738bb1fb89a8d27ec833ff0075b1d066b8b3ca21cd9832f477046 WHIRLPOOL 051956ab5c899ce98833925f84245f7450c7c01012edafdb6fff39762cf87908f53413c42f2ccb6059fd2717d29bf55ded260ade027b37ef0227a46b8266d8c7
+DIST multipath-tools-0.7.3.tar.gz 344030 SHA256 b59712c3068b9b33c2fc769eb499c637a0ddff7b46ae9d2cc411c4d61e233ffb SHA512 fbcd5609bcb4f80a91410cec86882e9f39ee056edb314382f25db8e1e1ed5c084e14849a67502be2b11a2e980dc2cb5d34235885476ae5ce62809a175bee9ace WHIRLPOOL 03b99202d2831513ba1fcc3e504ba3554b970c5bc366288a50e62e2225028dff972c102b7ae93d026026bea6614b5305a605122c91e0b8deeb91f9c98a68119f
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.7.3-fix-build-without-systemd.patch b/sys-fs/multipath-tools/files/multipath-tools-0.7.3-fix-build-without-systemd.patch
new file mode 100644
index 000000000000..d92e5c05c7d4
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.7.3-fix-build-without-systemd.patch
@@ -0,0 +1,39 @@
+From f0a874f9bd86504840a7bdbf0a0c07bcd0ea8c29 Mon Sep 17 00:00:00 2001
+From: Michael Lass <bevan@bi-co.net>
+Date: Wed, 20 Sep 2017 21:54:32 +0200
+Subject: [PATCH] multipathd: fix build without systemd
+
+do_sd_notify contains a call to sd_notify which is unknown if USE_SYSTEMD is
+undefined. In this case, do_sd_notify is never called anyway, so embed the
+entire function into an #ifdef USE_SYSTEMD.
+
+This fixes a regression introduced in 88ddca5.
+
+Signed-off-by: Michael Lass <bevan@bi-co.net>
+---
+ multipathd/main.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/multipathd/main.c b/multipathd/main.c
+index 8049da22..bbe14771 100644
+--- a/multipathd/main.c
++++ b/multipathd/main.c
+@@ -169,6 +169,7 @@ sd_notify_status(void)
+ return NULL;
+ }
+
++#ifdef USE_SYSTEMD
+ static void do_sd_notify(enum daemon_status old_state)
+ {
+ /*
+@@ -181,6 +182,7 @@ static void do_sd_notify(enum daemon_status old_state)
+ return;
+ sd_notify(0, sd_notify_status());
+ }
++#endif
+
+ static void config_cleanup(void *arg)
+ {
+--
+2.14.1
+
diff --git a/sys-fs/multipath-tools/multipath-tools-0.7.3.ebuild b/sys-fs/multipath-tools/multipath-tools-0.7.3.ebuild
new file mode 100644
index 000000000000..577cbe8db1b2
--- /dev/null
+++ b/sys-fs/multipath-tools/multipath-tools-0.7.3.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs udev vcs-snapshot toolchain-funcs
+
+DESCRIPTION="Device mapper target autoconfig"
+HOMEPAGE="http://christophe.varoqui.free.fr/"
+SRC_URI="http://git.opensvc.com/?p=multipath-tools/.git;a=snapshot;h=${PV};sf=tgz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="systemd rbd"
+
+RDEPEND="
+ dev-libs/json-c
+ dev-libs/libaio
+ dev-libs/userspace-rcu
+ >=sys-fs/lvm2-2.02.45
+ >=virtual/udev-171
+ sys-libs/readline:0=
+ rbd? ( sys-cluster/ceph )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+CONFIG_CHECK="~DM_MULTIPATH"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.7.3-fix-build-without-systemd.patch )
+
+get_systemd_pv() {
+ use systemd && \
+ $(tc-getPKG_CONFIG) --modversion systemd
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Fix for bug #624884
+ if grep -qF DM_TABLE_STATE kpartx/kpartx.rules ; then
+ sed '/DM_TABLE_STATE/d' -i kpartx/kpartx.rules || die
+ else
+ elog "DM_TABLE_STATE sed hack is no longer necessary."
+ fi
+
+ # The upstream lacks any way to configure the build at present
+ # and ceph is a huge dependency, so we're using sed to make it
+ # optional until the upstream has a proer configure system
+ if ! use rbd ; then
+ sed -i -e "s/libcheckrbd.so/# libcheckrbd.so/" libmultipath/checkers/Makefile
+ sed -i -e "s/-lrados//" libmultipath/checkers/Makefile
+ fi
+}
+
+src_compile() {
+ # LIBDM_API_FLUSH involves grepping files in /usr/include,
+ # so force the test to go the way we want #411337.
+ emake \
+ CC="$(tc-getCC)" \
+ LIBDM_API_FLUSH=1 SYSTEMD="$(get_systemd_pv)"
+}
+
+src_install() {
+ dodir /sbin /usr/share/man/man{5,8}
+ emake \
+ DESTDIR="${D}" \
+ SYSTEMD=$(get_systemd_pv) \
+ unitdir="$(systemd_get_systemunitdir)" \
+ libudevdir='${prefix}'/"$(get_udevdir)" \
+ install
+
+ newinitd "${FILESDIR}"/rc-multipathd multipathd
+ newinitd "${FILESDIR}"/multipath.rc multipath
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "If you need multipath on your system, you must"
+ elog "add 'multipath' into your boot runlevel!"
+ fi
+}