summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-08-08 13:26:22 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2016-08-08 13:26:22 -0700
commit8d3b290360cc437762d863d6f726b4e754b3582f (patch)
tree2a7f560d972accdfb1677d77e902d7deb9e2cd77 /sys-fs/multipath-tools
parentnet-irc/weechat: fix doc install, update guile dep, update to EAPI 6 (diff)
downloadgentoo-8d3b290360cc437762d863d6f726b4e754b3582f.tar.gz
gentoo-8d3b290360cc437762d863d6f726b4e754b3582f.tar.bz2
gentoo-8d3b290360cc437762d863d6f726b4e754b3582f.zip
sys-fs/multipath-tools: fix LDFLAGS on mpathpersist.
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-fs/multipath-tools')
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.6.2-makefile.patch2
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.6.2-r1.ebuild61
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.6.2-makefile.patch b/sys-fs/multipath-tools/files/multipath-tools-0.6.2-makefile.patch
index a051473cbd88..e5e28aa731fd 100644
--- a/sys-fs/multipath-tools/files/multipath-tools-0.6.2-makefile.patch
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.6.2-makefile.patch
@@ -127,7 +127,7 @@ diff -Nuar --exclude '*~' multipath-tools-e165b73.orig/mpathpersist/Makefile mul
$(EXEC): $(OBJS)
- $(CC) -g $(OBJS) -o $(EXEC) $(LDFLAGS) $(CFLAGS)
- $(GZIP) $(EXEC).8 > $(EXEC).8.gz
-+ $(CC) $(CFLAGS) $(CFLAGS) -g $(OBJS) -o $(EXEC) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -g $(OBJS) -o $(EXEC) $(LIBS)
install:
$(INSTALL_PROGRAM) -d $(DESTDIR)$(bindir)
diff --git a/sys-fs/multipath-tools/multipath-tools-0.6.2-r1.ebuild b/sys-fs/multipath-tools/multipath-tools-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..3ec454b244e1
--- /dev/null
+++ b/sys-fs/multipath-tools/multipath-tools-0.6.2-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils systemd toolchain-funcs udev
+
+DESCRIPTION="Device mapper target autoconfig"
+HOMEPAGE="http://christophe.varoqui.free.fr/"
+COMMIT_ID='e165b73a16fc9027aa3306df40052038c175be1b'
+SRC_URI="http://git.opensvc.com/?p=multipath-tools/.git;a=snapshot;h=${COMMIT_ID};sf=tgz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="systemd"
+
+RDEPEND=">=sys-fs/lvm2-2.02.45
+ >=virtual/udev-171
+ dev-libs/libaio
+ dev-libs/userspace-rcu
+ sys-libs/readline
+ systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${COMMIT_ID:0:7}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.2-makefile.patch
+)
+
+src_compile() {
+ # LIBDM_API_FLUSH involves grepping files in /usr/include,
+ # so force the test to go the way we want #411337.
+ emake LIBDM_API_FLUSH=1 CC="$(tc-getCC)" SYSTEMD=$(usex systemd 1 "")
+}
+
+src_install() {
+ local udevdir="$(get_udevdir)"
+
+ dodir /sbin /usr/share/man/man{5,8}
+ emake \
+ DESTDIR="${D}" \
+ SYSTEMD=$(usex systemd 1 "") \
+ unitdir="$(systemd_get_systemunitdir)" \
+ libudevdir='${prefix}'/"${udevdir}" \
+ install
+
+ newinitd "${FILESDIR}"/rc-multipathd multipathd
+ newinitd "${FILESDIR}"/multipath.rc multipath
+
+ dodoc README ChangeLog
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "If you need multipath on your system, you must"
+ elog "add 'multipath' into your boot runlevel!"
+ fi
+}