summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/obexfs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/obexfs')
-rw-r--r--sys-fs/obexfs/Manifest2
-rw-r--r--sys-fs/obexfs/metadata.xml12
-rw-r--r--sys-fs/obexfs/obexfs-0.11.ebuild23
-rw-r--r--sys-fs/obexfs/obexfs-0.12.ebuild26
4 files changed, 63 insertions, 0 deletions
diff --git a/sys-fs/obexfs/Manifest b/sys-fs/obexfs/Manifest
new file mode 100644
index 000000000000..42d496cb7870
--- /dev/null
+++ b/sys-fs/obexfs/Manifest
@@ -0,0 +1,2 @@
+DIST obexfs-0.11.tar.gz 86933 SHA256 4ff113dfa4f677e047fce0ee4da7c619adfe6087181376facbb605a38a347243
+DIST obexfs-0.12.tar.gz 83924 SHA256 72a62aeb4d4decff962f22239513651843857492e9d6b50f515c9bf9fccd73bc SHA512 f9b9c7c220271b7bf538d748beb3cb7fabd0377ef74855a959f7595755904be739ed5995909f423a40218d05a71de6b48a5ef471e2dc0934164aba2805c7e2e0 WHIRLPOOL 0355b71be7b393601bfcdbef791b061e284782135e6c3bd6164bbe304810e3be601279f1b5da3776528ec0aea41f829aab2560932c87cfa909fb4458fc9139f2
diff --git a/sys-fs/obexfs/metadata.xml b/sys-fs/obexfs/metadata.xml
new file mode 100644
index 000000000000..64ba3092b06f
--- /dev/null
+++ b/sys-fs/obexfs/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>Userspace filesystem used for accessing files on
+OBEX-capable mobile phones.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">openobex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/obexfs/obexfs-0.11.ebuild b/sys-fs/obexfs/obexfs-0.11.ebuild
new file mode 100644
index 000000000000..22c6554c0321
--- /dev/null
+++ b/sys-fs/obexfs/obexfs-0.11.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="FUSE filesystem interface for ObexFTP"
+HOMEPAGE="http://dev.zuckschwerdt.org/openobex/wiki/ObexFs"
+SRC_URI="http://triq.net/obexftp/${P/_/-}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=app-mobilephone/obexftp-0.22
+ sys-fs/fuse"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/${P%_*}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+}
diff --git a/sys-fs/obexfs/obexfs-0.12.ebuild b/sys-fs/obexfs/obexfs-0.12.ebuild
new file mode 100644
index 000000000000..b844b3b5b057
--- /dev/null
+++ b/sys-fs/obexfs/obexfs-0.12.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="FUSE filesystem interface for ObexFTP"
+HOMEPAGE="http://dev.zuckschwerdt.org/openobex/wiki/ObexFs"
+SRC_URI="mirror://sourceforge/openobex/files/${PN}/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=app-mobilephone/obexftp-0.22
+ sys-fs/fuse
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fix building, bug #523062 (from ArchLinux)
+ export OBEXFTP_CFLAGS="-I/usr/include/obexftp -I/usr/include/multicobex -I/usr/include/bfb"
+ export OBEXFTP_LIBS="-lobexftp -lmulticobex -lbfb -lopenobex -lbluetooth"
+}