summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/pytagsfs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/pytagsfs')
-rw-r--r--sys-fs/pytagsfs/Manifest2
-rw-r--r--sys-fs/pytagsfs/metadata.xml11
-rw-r--r--sys-fs/pytagsfs/pytagsfs-0.9.2.ebuild41
-rw-r--r--sys-fs/pytagsfs/pytagsfs-0.9.2_rc2.ebuild41
4 files changed, 95 insertions, 0 deletions
diff --git a/sys-fs/pytagsfs/Manifest b/sys-fs/pytagsfs/Manifest
new file mode 100644
index 000000000000..b61fd20931db
--- /dev/null
+++ b/sys-fs/pytagsfs/Manifest
@@ -0,0 +1,2 @@
+DIST pytagsfs-0.9.2.tar.gz 221155 SHA256 8b4e8e50432e8fe5b0c7bca62540f946ecfb606d07eb5ad0a9aeb28d9017635c
+DIST pytagsfs-0.9.2rc2.tar.gz 221043 SHA256 5916c5cb7a8cdb4e9cfe0dd51e5f55fa8031b72edd923f38382995776d78d4ed
diff --git a/sys-fs/pytagsfs/metadata.xml b/sys-fs/pytagsfs/metadata.xml
new file mode 100644
index 000000000000..2aad73845219
--- /dev/null
+++ b/sys-fs/pytagsfs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">pytagsfs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/pytagsfs/pytagsfs-0.9.2.ebuild b/sys-fs/pytagsfs/pytagsfs-0.9.2.ebuild
new file mode 100644
index 000000000000..8d948d285dab
--- /dev/null
+++ b/sys-fs/pytagsfs/pytagsfs-0.9.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+MY_PV="${PV/_/}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="File system that arranges media files based their tags"
+HOMEPAGE="https://launchpad.net/pytagsfs"
+SRC_URI="http://www.alittletooquiet.net/media/release/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND=">=dev-python/fuse-python-0.2-r1
+ >=dev-python/sclapp-0.5.2
+ || ( dev-python/inotifyx
+ ( dev-libs/libgamin[python]
+ app-admin/gam-server ) )
+ media-libs/mutagen"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ test? ( dev-python/inotifyx
+ dev-libs/libgamin[python]
+ app-admin/gam-server
+ media-sound/madplay
+ media-sound/vorbis-tools
+ media-libs/flac )"
diff --git a/sys-fs/pytagsfs/pytagsfs-0.9.2_rc2.ebuild b/sys-fs/pytagsfs/pytagsfs-0.9.2_rc2.ebuild
new file mode 100644
index 000000000000..58f6891fbb45
--- /dev/null
+++ b/sys-fs/pytagsfs/pytagsfs-0.9.2_rc2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* 2.7-pypy-* *-jython"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+MY_PV="${PV/_/}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="File system that arranges media files based their tags"
+HOMEPAGE="https://launchpad.net/pytagsfs"
+SRC_URI="http://www.alittletooquiet.net/media/release/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="dev-python/fuse-python
+ >=dev-python/sclapp-0.5.2
+ || ( dev-python/inotifyx
+ ( dev-libs/libgamin[python]
+ app-admin/gam-server ) )
+ media-libs/mutagen"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ test? ( dev-python/inotifyx
+ dev-libs/libgamin[python]
+ app-admin/gam-server
+ media-sound/madplay
+ media-sound/vorbis-tools
+ media-libs/flac )"