summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/rar2fs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/rar2fs')
-rw-r--r--sys-fs/rar2fs/Manifest1
-rw-r--r--sys-fs/rar2fs/metadata.xml16
-rw-r--r--sys-fs/rar2fs/rar2fs-1.20.0.ebuild28
3 files changed, 45 insertions, 0 deletions
diff --git a/sys-fs/rar2fs/Manifest b/sys-fs/rar2fs/Manifest
new file mode 100644
index 000000000000..edd2c9dd56c9
--- /dev/null
+++ b/sys-fs/rar2fs/Manifest
@@ -0,0 +1 @@
+DIST rar2fs-1.20.0.tar.gz 254330 SHA256 2b14cc5acefa12a07f5d0b1a4241713707e60e32f7a82cd86879ec1bd9cbae2d SHA512 a0136ee57b87da8846118282fb7fe70da2e07e7380c137e39ea45c16c6ef3400341b2034008cb261dc7c4d7b0ed666f43d0485374df05f3339c4aa52b7ca9164 WHIRLPOOL 69c15c483f18c895739f4bd9423314c288e45f3ea3cf582399a59a30842ea81a00343b636143ed955ea0b807068fbc4f7a3bb45188a7a4c77ab6588728391f4b
diff --git a/sys-fs/rar2fs/metadata.xml b/sys-fs/rar2fs/metadata.xml
new file mode 100644
index 000000000000..ee1594674128
--- /dev/null
+++ b/sys-fs/rar2fs/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">rar2fs</remote-id>
+ <remote-id type="github">hasse69/rar2fs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/rar2fs/rar2fs-1.20.0.ebuild b/sys-fs/rar2fs/rar2fs-1.20.0.ebuild
new file mode 100644
index 000000000000..6f3e94fd6612
--- /dev/null
+++ b/sys-fs/rar2fs/rar2fs-1.20.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A FUSE based filesystem that can mount one or multiple RAR archive(s)"
+HOMEPAGE="http://hasse69.github.io/rar2fs/ https://github.com/hasse69/rar2fs"
+SRC_URI="https://github.com/hasse69/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=app-arch/unrar-5:=
+ sys-fs/fuse"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog"
+
+src_configure() {
+ export USER_CFLAGS="${CFLAGS}"
+
+ econf \
+ --with-unrar=/usr/include/libunrar \
+ $(use_enable debug)
+}