summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/s3backer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/s3backer')
-rw-r--r--sys-fs/s3backer/Manifest1
-rw-r--r--sys-fs/s3backer/metadata.xml10
-rw-r--r--sys-fs/s3backer/s3backer-1.3.7.ebuild34
3 files changed, 45 insertions, 0 deletions
diff --git a/sys-fs/s3backer/Manifest b/sys-fs/s3backer/Manifest
new file mode 100644
index 000000000000..000ccbecf5b9
--- /dev/null
+++ b/sys-fs/s3backer/Manifest
@@ -0,0 +1 @@
+DIST s3backer-1.3.7.tar.gz 179068 SHA256 7a6f028d16301b0fd32679eebe34ff2d614f343979ee7a0fab0110b85934aaca SHA512 c3fae911e6b39cb211ac5d85c3d75cb6fd823243879d98d2a2b18644d22fe5a70a293d06c4e3c6559452d39cec80bbac9cea76965ead451bb0a145a61df8bc83 WHIRLPOOL 6906cb833deffb4218cfaca28f7f88116aff1dab7ddfd764452600b13b250da27ac672d98597f8f848b26bfcd70648291f97d2cd91155bb72c995792a6375bfe
diff --git a/sys-fs/s3backer/metadata.xml b/sys-fs/s3backer/metadata.xml
new file mode 100644
index 000000000000..45fcce25c7e2
--- /dev/null
+++ b/sys-fs/s3backer/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">s3backer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/s3backer/s3backer-1.3.7.ebuild b/sys-fs/s3backer/s3backer-1.3.7.ebuild
new file mode 100644
index 000000000000..37811d8c6dc6
--- /dev/null
+++ b/sys-fs/s3backer/s3backer-1.3.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="FUSE-based single file backing store via Amazon S3"
+HOMEPAGE="http://code.google.com/p/s3backer"
+SRC_URI="http://s3backer.googlecode.com/files/s3backer-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-misc/curl
+ sys-fs/fuse
+ sys-libs/zlib
+ dev-libs/expat
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e "/docdir=/s:packages/\$(PACKAGE):${PF}:" \
+ -e "/doc_DATA=/d" \
+ -i Makefile.am || die
+
+ eautoreconf
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}