summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-08-05 09:37:51 -0700
committerMatt Turner <mattst88@gentoo.org>2020-08-05 09:44:03 -0700
commit59c4a8cf5b971110349931f8589cddc375149923 (patch)
treeac7706d4908cb7a279f945eed4f4dc8d0387ef9b /sys-fs/squashfs-tools-ng
parentdev-db/innotop: drop old (diff)
downloadgentoo-59c4a8cf5b971110349931f8589cddc375149923.tar.gz
gentoo-59c4a8cf5b971110349931f8589cddc375149923.tar.bz2
gentoo-59c4a8cf5b971110349931f8589cddc375149923.zip
sys-fs/squashfs-tools-ng: Version bump to 1.0.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-fs/squashfs-tools-ng')
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest1
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.0.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
index 9e06bf6abec5..ec198d9b12eb 100644
--- a/sys-fs/squashfs-tools-ng/Manifest
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -1,2 +1,3 @@
DIST squashfs-tools-ng-0.9.1.tar.xz 1026036 BLAKE2B 3e0a0acf5b11ea42bad2149a9b97442739f1eceacfc0f5b009403d4616fcd02d69082e2e0721be3a1d6d9ba67ce6287b12ea13fba6409cb751e844f5d48ce7ea SHA512 eb550430917f267ec1ef1d11795167a6893031fc184f914170679cd24c16930a8f73a2b04a349ce1602e80a327957db7935369965a892fbe4904b6e01bb48b5c
DIST squashfs-tools-ng-1.0.0.tar.xz 1079912 BLAKE2B b7a9e4cafc31c0058d73b1a8b69125f92d753214f6e9f0372558271bbd8df163d9b3bf3fea45b96da5044c86e75affc2bfd27826d3725a35fbb417e443cf6ccb SHA512 536f12aa53214f88739cea0d26c55e04434c284935ff1d59ee8f5108acd92fc11e800e42e3a112524d09dbd1fa50c4f15c3211ff5d02ae50b7fa137600d2ae15
+DIST squashfs-tools-ng-1.0.1.tar.xz 1079720 BLAKE2B efc4d715c65d42876d5ac51364d195267c6bc6c2219fea5746231bc4efbd9adac3fa23ea58f837da8610179f3d96ec9422efebe4ae231f4ab243cf948e64fa9b SHA512 3b597b7bf654c6897e04dc6c18cec6034a8f0c0fe070c8d6eb3c8f4a06f4ab2ea8c970ac18c12f05ccb3015cf911790e945798a34361fdb7d1a442a1ca646a04
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.0.1.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.0.1.ebuild
new file mode 100644
index 000000000000..79c567828ddc
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-3+ tools? ( GPL-3+ )"
+SLOT="0"
+IUSE="lz4 lzo selinux +tools +xz zstd"
+
+DEPEND="
+ sys-libs/zlib:=
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:= )
+ xz? ( app-arch/xz-utils:= )
+ selinux? ( sys-libs/libselinux:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with tools)
+ $(use_with xz)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}