summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-09-23 11:51:14 -0700
committerMatt Turner <mattst88@gentoo.org>2020-09-23 11:51:21 -0700
commit78b788382a0d6a4eacaf192e50287fb917b4b779 (patch)
tree72fdacbe284cbe1d6a03c3561f47af085c4a01ab /sys-fs/squashfs-tools-ng
parentdev-python/yarl: Bump to 1.6.0 (diff)
downloadgentoo-78b788382a0d6a4eacaf192e50287fb917b4b779.tar.gz
gentoo-78b788382a0d6a4eacaf192e50287fb917b4b779.tar.bz2
gentoo-78b788382a0d6a4eacaf192e50287fb917b4b779.zip
sys-fs/squashfs-tools-ng: Version bump to 1.0.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-fs/squashfs-tools-ng')
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest1
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.0.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
index 3c4ad20a1774..ab123a063bcd 100644
--- a/sys-fs/squashfs-tools-ng/Manifest
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -1 +1,2 @@
DIST squashfs-tools-ng-1.0.1.tar.xz 1079720 BLAKE2B efc4d715c65d42876d5ac51364d195267c6bc6c2219fea5746231bc4efbd9adac3fa23ea58f837da8610179f3d96ec9422efebe4ae231f4ab243cf948e64fa9b SHA512 3b597b7bf654c6897e04dc6c18cec6034a8f0c0fe070c8d6eb3c8f4a06f4ab2ea8c970ac18c12f05ccb3015cf911790e945798a34361fdb7d1a442a1ca646a04
+DIST squashfs-tools-ng-1.0.2.tar.xz 1085300 BLAKE2B 59331a131bda9b9bae9f162f80abaeb99a6a3ea49958c1d2ce84968d3f010cdf803821a6f2230a173fcd1e7f5224f06b82463b84e31419a7a10a5ede2bee1a61 SHA512 d23d886c7f13046cae8b0e16c380d0c6e681d8921428357f30da9660200332e3dee8b072449c45ab858b0d9fa388d62eb748fb03d6182da6a8839e5ca806176b
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.0.2.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.0.2.ebuild
new file mode 100644
index 000000000000..79c567828ddc
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.0.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-3+ tools? ( GPL-3+ )"
+SLOT="0"
+IUSE="lz4 lzo selinux +tools +xz zstd"
+
+DEPEND="
+ sys-libs/zlib:=
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:= )
+ xz? ( app-arch/xz-utils:= )
+ selinux? ( sys-libs/libselinux:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with tools)
+ $(use_with xz)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}