summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-07 09:35:11 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-07 09:38:51 +0100
commit9f52de4016a77cff490a7b3631ce95262b3592e5 (patch)
treec0f477b94fb9a4021f413ffb96ea0240f3adab1e /sys-fs/squashfs-tools
parentsys-fs/squashfs-tools: Clean the ebuild up (diff)
downloadgentoo-9f52de4016a77cff490a7b3631ce95262b3592e5.tar.gz
gentoo-9f52de4016a77cff490a7b3631ce95262b3592e5.tar.bz2
gentoo-9f52de4016a77cff490a7b3631ce95262b3592e5.zip
sys-fs/squashfs-tools: Bump to 4.4-git.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs/squashfs-tools')
-rw-r--r--sys-fs/squashfs-tools/Manifest1
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.4_p1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools/Manifest b/sys-fs/squashfs-tools/Manifest
index 2893f2020861..952f1f088a00 100644
--- a/sys-fs/squashfs-tools/Manifest
+++ b/sys-fs/squashfs-tools/Manifest
@@ -1 +1,2 @@
+DIST squashfs-tools-4.4-git.1.tar.gz 241963 BLAKE2B 7a80c353efbbca851b2eb44e742f20b4cf59e91058b53b77c74d879dc18d882e3bb6de8a010a4469c0a53384ccf2968bba4cd1d6f10cfcede70fe07eebbf2409 SHA512 8d8cc3da7cbfc7b94d070021383413f3d1ef1261ba3fd9924dde4453558a8f8f14812c2f5614f87bef719496b0a023897de8d087c32a7344fa2eb9c1624563a0
DIST squashfs-tools-4.4.tar.gz 241842 BLAKE2B 006e2d340bcf6e20873221fb51fa30e0808c4a4d9e1838ca71c11ddbff3bf472dffe730e9edf07c34f535650e6486a8a80a88f82d6c9ef7a7c19aa22098e9197 SHA512 133ce437fb8c929933d52cff710b61dd9181f6f8be58250b0d6a59a7bb79a2b350f68f456b06a0e17c469409a71272d586802d570248273ddcd5dad088c00308
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.4_p1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.4_p1.ebuild
new file mode 100644
index 000000000000..01661bc54be2
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.4_p1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic toolchain-funcs
+
+MY_P=${P/_p/-git.}
+DESCRIPTION="tools to create and extract Squashfs filesystems"
+HOMEPAGE="https://github.com/plougher/squashfs-tools/"
+SRC_URI="
+ https://github.com/plougher/squashfs-tools/archive/${PV/_p/-git.}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="debug lz4 lzma lzo xattr zstd"
+
+RDEPEND="
+ sys-libs/zlib
+ lz4? ( app-arch/lz4 )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ xattr? ( sys-apps/attr )
+ zstd? ( app-arch/zstd )
+"
+DEPEND=${RDEPEND}
+
+use10() { usex "${1}" 1 0; }
+
+src_configure() {
+ # set up make command line variables in EMAKE_SQUASHFS_CONF
+ EMAKE_SQUASHFS_CONF=(
+ LZMA_XZ_SUPPORT=$(use10 lzma)
+ LZO_SUPPORT=$(use10 lzo)
+ LZ4_SUPPORT=$(use10 lz4)
+ XATTR_SUPPORT=$(use10 xattr)
+ XZ_SUPPORT=$(use10 lzma)
+ ZSTD_SUPPORT=$(use10 zstd)
+ )
+
+ tc-export CC
+ use debug && append-cppflags -DSQUASHFS_TRACE
+}
+
+src_compile() {
+ emake "${EMAKE_SQUASHFS_CONF[@]}" -C squashfs-tools
+}
+
+src_install() {
+ dobin squashfs-tools/{mksquashfs,unsquashfs}
+ dodoc ACKNOWLEDGEMENTS CHANGES README*
+ dodoc -r RELEASE-READMEs
+}