summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/udisks/udisks-2.1.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/udisks/udisks-2.1.4.ebuild')
-rw-r--r--sys-fs/udisks/udisks-2.1.4.ebuild102
1 files changed, 102 insertions, 0 deletions
diff --git a/sys-fs/udisks/udisks-2.1.4.ebuild b/sys-fs/udisks/udisks-2.1.4.ebuild
new file mode 100644
index 000000000000..07988ef711e5
--- /dev/null
+++ b/sys-fs/udisks/udisks-2.1.4.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit bash-completion-r1 eutils linux-info systemd udev
+
+DESCRIPTION="Daemon providing interfaces to work with storage devices"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/udisks"
+SRC_URI="http://udisks.freedesktop.org/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86"
+IUSE="debug cryptsetup +gptfdisk +introspection selinux systemd"
+
+COMMON_DEPEND=">=dev-libs/glib-2.36
+ >=dev-libs/libatasmart-0.19
+ >=sys-auth/polkit-0.110
+ virtual/acl
+ virtual/libgudev:=
+ virtual/udev
+ introspection? ( >=dev-libs/gobject-introspection-1.30 )
+ systemd? ( sys-apps/systemd )"
+# gptfdisk -> src/udiskslinuxpartition.c -> sgdisk (see also #412801#c1)
+# util-linux -> mount, umount, swapon, swapoff (see also #403073)
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/util-linux-2.20.1-r2
+ >=sys-block/parted-3
+ virtual/eject
+ cryptsetup? (
+ sys-fs/cryptsetup[udev(+)]
+ sys-fs/lvm2[udev(+)]
+ )
+ gptfdisk? ( >=sys-apps/gptfdisk-0.8 )
+ selinux? ( sec-policy/selinux-devicekit )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.32
+ dev-util/intltool
+ >=sys-kernel/linux-headers-3.1
+ virtual/pkgconfig"
+
+QA_MULTILIB_PATHS="usr/lib/udisks2/udisksd"
+
+DOCS="AUTHORS HACKING NEWS README"
+
+pkg_setup() {
+ # Listing only major arch's here to avoid tracking kernel's defconfig
+ if use amd64 || use arm || use ppc || use ppc64 || use x86; then
+ CONFIG_CHECK="~!IDE" #319829
+ CONFIG_CHECK+=" ~TMPFS_POSIX_ACL" #412377
+ CONFIG_CHECK+=" ~SWAP" # http://forums.gentoo.org/viewtopic-t-923640.html
+ CONFIG_CHECK+=" ~NLS_UTF8" #425562
+ kernel_is lt 3 10 && CONFIG_CHECK+=" ~USB_SUSPEND" #331065, #477278
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ use systemd || { sed -i -e 's:libsystemd-login:&disable:' configure || die; }
+
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}"/var \
+ --disable-static \
+ $(use_enable debug) \
+ --disable-gtk-doc \
+ $(use_enable introspection) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --with-udevdir="$(get_udevdir)" \
+ "$(systemd_with_unitdir)"
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ keepdir /var/lib/udisks2 #383091
+
+ rm -rf "${ED}"/usr/share/bash-completion
+ dobashcomp data/completions/udisksctl
+
+ local htmldir=udisks2
+ if [[ -d ${ED}/usr/share/doc/${PF}/html/${htmldir} ]]; then
+ dosym /usr/share/doc/${PF}/html/${htmldir} /usr/share/gtk-doc/html/${htmldir}
+ fi
+}
+
+pkg_postinst() {
+ mkdir -p "${EROOT}"/run #415987
+
+ # See pkg_postinst() of >=sys-apps/baselayout-2.1-r1. Keep in sync?
+ if ! grep -qs "^tmpfs.*/run " "${EROOT}"/proc/mounts ; then
+ echo
+ ewarn "You should reboot the system now to get /run mounted with tmpfs!"
+ fi
+}