summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/unionfs-fuse/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/unionfs-fuse/files')
-rw-r--r--sys-fs/unionfs-fuse/files/unionfs-fuse-0.23-makefile.patch15
-rw-r--r--sys-fs/unionfs-fuse/files/unionfs-fuse-0.26-declare-chroot.patch12
-rw-r--r--sys-fs/unionfs-fuse/files/unionfs-fuse-0.26-link-pthread.patch11
3 files changed, 38 insertions, 0 deletions
diff --git a/sys-fs/unionfs-fuse/files/unionfs-fuse-0.23-makefile.patch b/sys-fs/unionfs-fuse/files/unionfs-fuse-0.23-makefile.patch
new file mode 100644
index 000000000000..6f80808dce75
--- /dev/null
+++ b/sys-fs/unionfs-fuse/files/unionfs-fuse-0.23-makefile.patch
@@ -0,0 +1,15 @@
+--- Makefile_BACKUP 2010-01-12 01:26:33.000000000 +0100
++++ Makefile 2010-01-12 01:26:58.000000000 +0100
+@@ -7,10 +7,10 @@
+ LIB = -lfuse -lpthread -lm
+
+ build:
+- make -C src/
++ $(MAKE) -C src/
+
+ clean:
+- make -C src/ clean
++ $(MAKE) -C src/ clean
+
+ install: build
+ cp src/unionfs $(DESTDIR)/sbin/
diff --git a/sys-fs/unionfs-fuse/files/unionfs-fuse-0.26-declare-chroot.patch b/sys-fs/unionfs-fuse/files/unionfs-fuse-0.26-declare-chroot.patch
new file mode 100644
index 000000000000..e436f9f01575
--- /dev/null
+++ b/sys-fs/unionfs-fuse/files/unionfs-fuse-0.26-declare-chroot.patch
@@ -0,0 +1,12 @@
+--- unionfs-fuse-0.26/src/unionfs.c 2012-09-22 22:24:05.090568485 +0200
++++ unionfs-fuse-0.26/src/unionfs.c 2012-09-22 22:24:09.036519156 +0200
+@@ -13,6 +13,9 @@
+ #ifdef linux
+ // For pread()/pwrite()/utimensat()
+ #define _XOPEN_SOURCE 700
++
++ // For chroot
++ #define _BSD_SOURCE
+ #endif
+
+ #include <fuse.h>
diff --git a/sys-fs/unionfs-fuse/files/unionfs-fuse-0.26-link-pthread.patch b/sys-fs/unionfs-fuse/files/unionfs-fuse-0.26-link-pthread.patch
new file mode 100644
index 000000000000..9bed29fe2ed7
--- /dev/null
+++ b/sys-fs/unionfs-fuse/files/unionfs-fuse-0.26-link-pthread.patch
@@ -0,0 +1,11 @@
+--- src/Makefile 2012-09-22 22:14:36.484677038 +0200
++++ src/Makefile 2012-09-22 22:14:40.162631059 +0200
+@@ -5,7 +5,7 @@
+
+ LDFLAGS +=
+
+-LIB = $(shell pkg-config --libs fuse)
++LIB = $(shell pkg-config --libs fuse) -lpthread
+
+ HASHTABLE_OBJ = hashtable.o hashtable_itr.o
+ UNIONFS_OBJ = unionfs.o stats.o opts.o debug.o findbranch.o readdir.o \