summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-04-12 18:51:44 +0200
committerSebastian Pipping <sping@gentoo.org>2020-04-12 18:52:21 +0200
commit4ccf4f1b7726ef47f905d722fa265b69ea5b7c2a (patch)
treeba7af30bd2d20d26a3ceacc927697c41efc6a733 /sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
parentdev-lang/gnat-gpl: fix build with glibc-2.31 (diff)
downloadgentoo-4ccf4f1b7726ef47f905d722fa265b69ea5b7c2a.tar.gz
gentoo-4ccf4f1b7726ef47f905d722fa265b69ea5b7c2a.tar.bz2
gentoo-4ccf4f1b7726ef47f905d722fa265b69ea5b7c2a.zip
sys-fs/unionfs-fuse: 2.1 + EAPI 7 + tests + sync 9999
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.98, Repoman-2.3.22
Diffstat (limited to 'sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild')
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
new file mode 100644
index 000000000000..2c3037f0258e
--- /dev/null
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-any-r1
+
+DESCRIPTION="Self-syncing tree-merging file system based on FUSE"
+HOMEPAGE="https://github.com/rpodgorny/unionfs-fuse"
+SRC_URI="https://github.com/rpodgorny/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-fs/fuse:0"
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+python_check_deps() {
+ use test || return 0
+ has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}
+
+src_test() {
+ addwrite /dev/fuse
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}