summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-02-03 21:14:08 +0100
committerSebastian Pipping <sping@gentoo.org>2021-02-03 21:17:11 +0100
commitcc02ef6bfb9ac2be37076939a7f120c2bfb373ba (patch)
tree35059721028284270750cba7a9e3774c8ebb6af5 /sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
parentnet-firewall/shorewall: fix incomplete EAPI 7 migration (diff)
downloadgentoo-cc02ef6bfb9ac2be37076939a7f120c2bfb373ba.tar.gz
gentoo-cc02ef6bfb9ac2be37076939a7f120c2bfb373ba.tar.bz2
gentoo-cc02ef6bfb9ac2be37076939a7f120c2bfb373ba.zip
sys-fs/unionfs-fuse: Skip tests when missing /dev/fuse
Closes: https://bugs.gentoo.org/729094 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.14, Repoman-3.0.2
Diffstat (limited to 'sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild')
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
index b9d37ded3403..329020ca1173 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -41,6 +41,7 @@ src_install() {
}
src_test() {
+ [[ -e /dev/fuse ]] || return 0
addwrite /dev/fuse
pytest -vv || die "Tests fail with ${EPYTHON}"
}