summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-07-27 17:43:01 +0200
committerSebastian Pipping <sping@gentoo.org>2020-07-27 17:44:30 +0200
commit23044dcd951cff4f40b4cc183bee80c9a2fa1ac6 (patch)
tree0df02353d2cb9ede0078d5f66db2f01640928dc4 /sys-fs/unionfs-fuse
parentsys-libs/glibc: Bump locale-gen version (diff)
downloadgentoo-23044dcd951cff4f40b4cc183bee80c9a2fa1ac6.tar.gz
gentoo-23044dcd951cff4f40b4cc183bee80c9a2fa1ac6.tar.bz2
gentoo-23044dcd951cff4f40b4cc183bee80c9a2fa1ac6.zip
sys-fs/unionfs-fuse: Pass variables CC and AR
Closes: https://bugs.gentoo.org/732372 Thanks for the patch to Gavin Pryke! Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
Diffstat (limited to 'sys-fs/unionfs-fuse')
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild6
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
index 2c3037f0258e..480634c6bacb 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
@@ -4,7 +4,7 @@
EAPI="7"
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-any-r1
+inherit python-any-r1 toolchain-funcs
DESCRIPTION="Self-syncing tree-merging file system based on FUSE"
HOMEPAGE="https://github.com/rpodgorny/unionfs-fuse"
@@ -32,6 +32,10 @@ python_check_deps() {
has_version "dev-python/pytest[${PYTHON_USEDEP}]"
}
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
}
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
index 914a41411a91..b935d86f2bc3 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
@@ -4,7 +4,7 @@
EAPI="7"
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-any-r1 git-r3
+inherit python-any-r1 toolchain-funcs git-r3
DESCRIPTION="Self-syncing tree-merging file system based on FUSE"
HOMEPAGE="https://github.com/rpodgorny/unionfs-fuse"
@@ -32,6 +32,10 @@ python_check_deps() {
has_version "dev-python/pytest[${PYTHON_USEDEP}]"
}
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
}