summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-10-26 00:09:10 -0400
committerMike Frysinger <vapier@gentoo.org>2015-10-26 00:15:44 -0400
commitd3fcf50e0abe50480b1676ad861acbbf7220b3a8 (patch)
treee55ddb2c6dc4d3eb7cd5d74ff1e58102eb6d2b04 /sys-fs/xfsdump/xfsdump-3.1.5.ebuild
parentdev-python/elasticsearch-py: fix to code re IUSE doc, fixes the gentoo bug (diff)
downloadgentoo-d3fcf50e0abe50480b1676ad861acbbf7220b3a8.tar.gz
gentoo-d3fcf50e0abe50480b1676ad861acbbf7220b3a8.tar.bz2
gentoo-d3fcf50e0abe50480b1676ad861acbbf7220b3a8.zip
sys-fs/xfsdump: version bump to 3.1.5 #560358
Diffstat (limited to 'sys-fs/xfsdump/xfsdump-3.1.5.ebuild')
-rw-r--r--sys-fs/xfsdump/xfsdump-3.1.5.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-fs/xfsdump/xfsdump-3.1.5.ebuild b/sys-fs/xfsdump/xfsdump-3.1.5.ebuild
new file mode 100644
index 000000000000..b64e028716d5
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-3.1.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit multilib eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/e2fsprogs
+ >=sys-fs/xfsprogs-3.2.0
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die
+ epatch "${FILESDIR}"/${PN}-3.0.5-prompt-overflow.patch #335115
+ epatch "${FILESDIR}"/${PN}-3.0.4-no-symlink.patch #311881
+
+ # The release when used with xfsprogs-4.2+ is ... a mess.
+ epatch "${FILESDIR}"/${P}-config-platform.patch
+ find -type f -name '*.c' -exec sed -i \
+ -e '1i#include "config.h"' \
+ -e '1i#include <assert.h>' \
+ -e '1i#include <fcntl.h>' \
+ -e '1i#include <stdarg.h>' \
+ -e '1i#include <stdlib.h>' \
+ -e '1i#include <string.h>' \
+ -e '1i#include <unistd.h>' \
+ -e '1i#include <sys/wait.h>' \
+ {} + || die
+}
+
+src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir="${EPREFIX}/$(get_libdir)" \
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)" \
+ --sbindir="${EPREFIX}/sbin"
+}